Jump to content

CHALLENGER PRIME Problems


dvanteb
 Share

Recommended Posts

  • 3 weeks later...

Well this thread made me sad (Game Mode vs Windows Mode).

 

I got this "gaming keyboard" to use outside of gaming. Would never have thought that such a bad design choice would be made. Macros are not only a gaming thing.

 

Whenever there is "one or the other" usually this can be solved with "Why not both?"...

 

I have a "gaming mouse" that doesn't differentiate if you are in a game. BUT the good news is there are other "gaming keyboards" that don't take such a myopic view on this.

 

Really hope that this gets patched...

Link to comment
Share on other sites

Guest Tt Josh

Well this thread made me sad (Game Mode vs Windows Mode).

 

I got this "gaming keyboard" to use outside of gaming. Would never have thought that such a bad design choice would be made. Macros are not only a gaming thing.

 

Whenever there is "one or the other" usually this can be solved with "Why not both?"...

 

I have a "gaming mouse" that doesn't differentiate if you are in a game. BUT the good news is there are other "gaming keyboards" that don't take such a myopic view on this.

 

Really hope that this gets patched...

Thanks for the feedback. We are currently working to fix the problem for you guys as many of you brought up the same issue, sorry for the inconvenience. :)

 

We will provide you guys the update when we have more information on that.

Link to comment
Share on other sites

I only registered to +1 this. I RMA'd my board thinking the Windows Key was busted, but then had this happen again and figured it couldn't be two boards. This re-enabled the left windows key not working.

 

Thanks for the contrib.

 

 

I had the same issue when I got this keyboard. The reason this has occurred is the keyboard is in game mode. Apparently, when in game mode, the windows key is disabled. The fix is easy, just put the keyboard back into normal mode. This can be accomplished by holding down the (Fn) button, then pressing the (PrtScr/SysRq) button, just to the right of the F12 button. Now your windows key should be active. Hope this helps.

Link to comment
Share on other sites

So, I tried running the setup, and when you choose the setup folder, it won't let me continue. The setup window gives an error, reading "String ER_Create_Reg was not found in string table." After I click OK on that, another error pops up, reading "ER_Create_Reg" and when I click OK, setup crashes. How do I get around this or fix it?

Link to comment
Share on other sites

Guest Tt Josh

So, I tried running the setup, and when you choose the setup folder, it won't let me continue. The setup window gives an error, reading "String ER_Create_Reg was not found in string table." After I click OK on that, another error pops up, reading "ER_Create_Reg" and when I click OK, setup crashes. How do I get around this or fix it?

Here's the current software: CHALLENGER PRIME GAMING SOFTWARE VERSION 3.0

Link to comment
Share on other sites

  • 2 months later...

yes in highest setting (100% in the software also) in normal mode is less brighter then in gaming mode (also in highest setting).

Is there any problem? should i clame it in rma? Pls help

 

Try Fn+Pause/Break (it changes color) -- when it changes back to your chosen color, it should be in full brightness, at least mine did that.  Hope this helps.

Link to comment
Share on other sites

  • 9 months later...
  • 4 weeks later...
  • 1 month later...
  • 5 months later...
  • 1 month later...
On 4/19/2016 at 11:20 AM, Guest Tt Josh said:

We are currently working on having windows key enabled while in game mode, we will provide you guys further information when it's ready. :)

It's been nearly two years since you said this, and at least three since the problem was first noticed. When is this going to get fixed?

Besides, having Windows key work in gaming mode isn't what people want. We want macros to work in non-gaming mode. It would also be nice if the software made it clear what's what. Currently the software makes it appear as though there is one gaming mode and three regular modes, but actually it seems to be more like three gaming modes and one regular?

Link to comment
Share on other sites

On 11/9/2015 at 6:26 PM, Guest Tt Josh said:

I don't see we are ignoring users here as we still helping users to escalate every time an user brought up issues like this

You, Josh, are not ignoring users. You're not the problem. However, "you" in the broad sense, meaning Thermaltake, are clearly ignoring users. Because this problem has been ongoing for three years now and there is no appreciable work being done to fix it.

Link to comment
Share on other sites

  • 5 months later...
  • 5 months later...

I have downloaded all the drivers and software but I cannot change any settings on my TT Challenger Edge pro keyboard as the Thermaltake program does not recognize my keyboard - "Please plug in Thermaltake device to get started" I'm currently typing with it so I have no idea what I am meant to do. I have tried everything. Any ideas?

Link to comment
Share on other sites

  • 8 months later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...