Jump to content

Welcome to Tt Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Note:
If you are experiencing technical difficulties with your registration process, or if you have not received a confirmation mail, please drop an e-mail to ttcommunity@thermaltake.com with your registered username/e-mail. We will sort out your request as soon as possible, sorry for any inconvenience

Photo

CHALLENGER PRIME Problems


  • Please log in to reply
35 replies to this topic

#21
intothefire

intothefire

    Beginner

  • Members
  • Pip
  • 1 posts

I have an issue when playing Skyrim... When i'm in game the multimedia keys doesn't work at all (pause, mute, volum+/-, etc) what could be the problem?? anyone who have the same issue? help :C



#22
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

I have an issue when playing Skyrim... When i'm in game the multimedia keys doesn't work at all (pause, mute, volum+/-, etc) what could be the problem?? anyone who have the same issue? help :C

Hi, did you try to plug it to another USB port?



#23
Keeks

Keeks

    Beginner

  • Members
  • Pip
  • 6 posts

This is incredibly annoying, I use the macro keys on the left for volume settings, as the keys on the top are too far to adjust fast, but the keys dont work when Gaming mode isnt on.  But the problem is when Gaming mode is on I cant use the windows key and there are NO options at all to change this.  Please allow us to customize gaming mode there is absolutely no reason or sense in forcing users to use your settings



#24
Keeks

Keeks

    Beginner

  • Members
  • Pip
  • 6 posts

I shouldnt have to choose between Windows key or Macro keys that makes no sense



#25
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

I shouldnt have to choose between Windows key or Macro keys that makes no sense

Hi, this issue has already been brought up by a lot of our fans our there and it has already been passed to the appropriate team. The team will look into it accordingly.



#26
Keeks

Keeks

    Beginner

  • Members
  • Pip
  • 6 posts

Hi, this issue has already been brought up by a lot of our fans our there and it has already been passed to the appropriate team. The team will look into it accordingly.

When will it be fixed? 



#27
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

When will it be fixed? 

We will need to wait for the appropriate team to inform us about the news. For now, game mode will disable the windows key.



#28
Keeks

Keeks

    Beginner

  • Members
  • Pip
  • 6 posts

We will need to wait for the appropriate team to inform us about the news. For now, game mode will disable the windows key.

This problem was first reported over a year ago you are bullshitting and nothing is coming.  Going to return my keyboard after work tomorrow


  • HeyYahBLah likes this

#29
Keeks

Keeks

    Beginner

  • Members
  • Pip
  • 6 posts

and id advise everyone else to do the same who has this problem, they have shown they do not care


  • HeyYahBLah likes this

#30
rice lice

rice lice

    Beginner

  • Members
  • Pip
  • 1 posts

Well this thread made me sad (Game Mode vs Windows Mode).

 

I got this "gaming keyboard" to use outside of gaming. Would never have thought that such a bad design choice would be made. Macros are not only a gaming thing.

 

Whenever there is "one or the other" usually this can be solved with "Why not both?"...

 

I have a "gaming mouse" that doesn't differentiate if you are in a game. BUT the good news is there are other "gaming keyboards" that don't take such a myopic view on this.

 

Really hope that this gets patched...



#31
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

Well this thread made me sad (Game Mode vs Windows Mode).

 

I got this "gaming keyboard" to use outside of gaming. Would never have thought that such a bad design choice would be made. Macros are not only a gaming thing.

 

Whenever there is "one or the other" usually this can be solved with "Why not both?"...

 

I have a "gaming mouse" that doesn't differentiate if you are in a game. BUT the good news is there are other "gaming keyboards" that don't take such a myopic view on this.

 

Really hope that this gets patched...

Thanks for the feedback. We are currently working to fix the problem for you guys as many of you brought up the same issue, sorry for the inconvenience. :)

 

We will provide you guys the update when we have more information on that.



#32
MT-

MT-

    Beginner

  • Members
  • Pip
  • 1 posts

I only registered to +1 this. I RMA'd my board thinking the Windows Key was busted, but then had this happen again and figured it couldn't be two boards. This re-enabled the left windows key not working.

 

Thanks for the contrib.

 

 

I had the same issue when I got this keyboard. The reason this has occurred is the keyboard is in game mode. Apparently, when in game mode, the windows key is disabled. The fix is easy, just put the keyboard back into normal mode. This can be accomplished by holding down the (Fn) button, then pressing the (PrtScr/SysRq) button, just to the right of the F12 button. Now your windows key should be active. Hope this helps.



#33
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

We are currently working on having windows key enabled while in game mode, we will provide you guys further information when it's ready. :)



#34
Problem???

Problem???

    Beginner

  • Members
  • Pip
  • 1 posts

So, I tried running the setup, and when you choose the setup folder, it won't let me continue. The setup window gives an error, reading "String ER_Create_Reg was not found in string table." After I click OK on that, another error pops up, reading "ER_Create_Reg" and when I click OK, setup crashes. How do I get around this or fix it?



#35
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

So, I tried running the setup, and when you choose the setup folder, it won't let me continue. The setup window gives an error, reading "String ER_Create_Reg was not found in string table." After I click OK on that, another error pops up, reading "ER_Create_Reg" and when I click OK, setup crashes. How do I get around this or fix it?

Here's the current software: CHALLENGER PRIME GAMING SOFTWARE VERSION 3.0



#36
0x6A7232

0x6A7232

    Beginner

  • Members
  • Pip
  • 1 posts

yes in highest setting (100% in the software also) in normal mode is less brighter then in gaming mode (also in highest setting).
Is there any problem? should i clame it in rma? Pls help

 

Try Fn+Pause/Break (it changes color) -- when it changes back to your chosen color, it should be in full brightness, at least mine did that.  Hope this helps.






3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users