Jump to content
baldcarrots

SAPHIRA Scroll Wheel Issues

Recommended Posts

I have owned my SAPHIRA for about 2 years and love it to death. It is by far the most comfortable mouse I've used and I love the simple design. For the past year or so, the scroll wheel has been acting up. When scrolling down there are no issues but when I attempt to scroll up the pattern is jumpy and very buggy. As an example, if i am scrolling up on a web page, the page scrolls for 2-3 ticks then shoots back down instantly about twice the distance I just scrolled up. This results in a page actually moving down when I try to scroll up. I'm not sure if this is a known issue but a friend of mine had the same issue with his SAPHIRA last year. Other than this issue the mouse is in prime condition and I don't want to have to buy a new one just to get the scroll wheel to work. Has anyone else experienced this issue?

Share this post


Link to post
Share on other sites
Guest Tt Josh   
Guest Tt Josh

I have owned my SAPHIRA for about 2 years and love it to death. It is by far the most comfortable mouse I've used and I love the simple design. For the past year or so, the scroll wheel has been acting up. When scrolling down there are no issues but when I attempt to scroll up the pattern is jumpy and very buggy. As an example, if i am scrolling up on a web page, the page scrolls for 2-3 ticks then shoots back down instantly about twice the distance I just scrolled up. This results in a page actually moving down when I try to scroll up. I'm not sure if this is a known issue but a friend of mine had the same issue with his SAPHIRA last year. Other than this issue the mouse is in prime condition and I don't want to have to buy a new one just to get the scroll wheel to work. Has anyone else experienced this issue?

Hey baldcarrots, where are you currently located? We will have our local office colleagues to assist you further on the issue. ;)

Share this post


Link to post
Share on other sites

Hey baldcarrots, where are you currently located? We will have our local office colleagues to assist you further on the issue. ;)

I'm in Ontario, Canada. Is there someway I can contact someone about the issue through email?

Share this post


Link to post
Share on other sites
Guest Tt Josh   
Guest Tt Josh

I'm in Ontario, Canada. Is there someway I can contact someone about the issue through email?

Hey baldcarrots,

 

Please contact Customer Support for after sales service.

We would like you to have a fully functional unit with no discrepancies!

Please contact Customer Support at your earliest convenience.

 

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

Share this post


Link to post
Share on other sites

Hey baldcarrots,

 

Please contact Customer Support for after sales service.

We would like you to have a fully functional unit with no discrepancies!

Please contact Customer Support at your earliest convenience.

 

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

I sent an e-mail and they told me to submit an RMA request form. Unfortunately I don't have my receipt an longer. The mouse still functions and I'll just wait until I replace it fully I guess. Thanks for your help though.

Share this post


Link to post
Share on other sites

I have owned my SAPHIRA for about 2 years and love it to death. It is by far the most comfortable mouse I've used and I love the simple design. For the past year or so, the scroll wheel has been acting up. When scrolling down there are no issues but when I attempt to scroll up the pattern is jumpy and very buggy. As an example, if i am scrolling up on a web page, the page scrolls for 2-3 ticks then shoots back down instantly about twice the distance I just scrolled up. This results in a page actually moving down when I try to scroll up. I'm not sure if this is a known issue but a friend of mine had the same issue with his SAPHIRA last year. Other than this issue the mouse is in prime condition and I don't want to have to buy a new one just to get the scroll wheel to work. Has anyone else experienced this issue?

Hello Baldcarrots,

 

I am exactly with the same problem... Do you already fixed it?

 

Thank you.

Share this post


Link to post
Share on other sites
Guest Tt Josh   
Guest Tt Josh

Hello Baldcarrots,

 

I am exactly with the same problem... Do you already fixed it?

 

Thank you.

Hey Faalso, please contact our customer support and we will have our local staff to assist you further on the mouse! ;)

Share this post


Link to post
Share on other sites

Hey Faalso, please contact our customer support and we will have our local staff to assist you further on the mouse! ;)

Thank you... Do you know How could I find a local staff in Brazil please?

 

Thank you again...

Share this post


Link to post
Share on other sites
Guest Tt Josh   
Guest Tt Josh

Hey Faalso, for Brazil's inquiries, you can also send the inquiry to ttsupport@thermaltakeusa.com...we will have someone to assist you :)

Share this post


Link to post
Share on other sites
Guest Tt Josh   
Guest Tt Josh

I've been getting this same issue. Is there a fix for it? If not, is there support that I can contact here in Australia?

Hey Gunofthedeep, please contact our customer support at rma@thermaltake.com.au and we will have our customer support to assist you further on the issue. :)

Share this post


Link to post
Share on other sites

Hi,

 

I actually have the same issue as yours, how did you resolve it? I emailed tt esports support last year and I receive no reply regarding this. It's kinda bugging me as mouse scroll is one of the most important part of the mouse.

 

Do you guys have support here in the philippines?

 

By the way, I bought my saphira around May 2014.

Share this post


Link to post
Share on other sites
Guest Tt Josh   
Guest Tt Josh

Hi,

 

I actually have the same issue as yours, how did you resolve it? I emailed tt esports support last year and I receive no reply regarding this. It's kinda bugging me as mouse scroll is one of the most important part of the mouse.

 

Do you guys have support here in the philippines?

 

By the way, I bought my saphira around May 2014.

Hi arnienobleza, please contact our customer support at cs2@thermaltake.com and we will have someone to assist you further.

Share this post


Link to post
Share on other sites

I'm having the same issue with my Saphira (I'm at Argentina). It lasted less than two years. I'd be glad to read an acknowledgement of the problem or how to fix it -instead of how to contact support  :(-.

I bought this mouse thinking it would last more than the average simple mouse from which I upgraded (worked for 6+ years and still going). 

Share this post


Link to post
Share on other sites
Guest Tt Josh   
Guest Tt Josh

I'm having the same issue with my Saphira (I'm at Argentina). It lasted less than two years. I'd be glad to read an acknowledgement of the problem or how to fix it -instead of how to contact support  :(-.

I bought this mouse thinking it would last more than the average simple mouse from which I upgraded (worked for 6+ years and still going). 

Hi Zimmund,

 

You will surely need to contact them as it's because of the mouse you're using causing the problem.

 

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

Share this post


Link to post
Share on other sites

Hi Zimmund,

 

You will surely need to contact them as it's because of the mouse you're using causing the problem.

 

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

 

I have the same problem too! I emailed ttsupport@thermaltakeusa.com last night. Hopefully I get a reply soon!  

Share this post


Link to post
Share on other sites

Hi guys,

 

For some time I have had this issue on my Saphira mouse, I scroll up and it jumps down so quite frustrating. Otherwise I love the mouse.  Is there a fix for this?  Should I contact support?

 

I am in the UK.

 

Thanks.

Share this post


Link to post
Share on other sites
The wheel problem solves it by forcing the sensor holder towards the inner side, very carefully. So the wheel fits better and does not make the rebound error any more.

First, two screws are removed under the bottom slider.

Then remove the upper housing, remove four more screws and release the lower housing.

Turn the wheel plate and remove the wheel. We clean and very carefully force the sensor holder in, very little.

The wheel is placed and the plate is returned to its place. Without assembling it is proved. It is repeated if it still makes the mistake. It is assembled following the reverse steps.


I hope it serves them. Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×