Jump to content
  • Forum Statistics

    7,825
    Total Topics
    41,508
    Total Posts
  • Member Statistics

    48,720
    Total Members
    16,800
    Most Online
    Thể Thao Yes
    Newest Member
    Thể Thao Yes
    Joined

Paulo

Members
  • Content Count

    2
  • Joined

  • Last visited

  1. I found out that TT is now selling the cable separately: http://es.thermaltake.com/Chassis/Accessories_/_/C_00002784/PCI_e_X16_Riser_Cable/Design.htm It's funny that some users still didn't get their cables (me included) and meanwhile TT managed to get cable stock to start selling the cables... At the moment, reading what some users report, I'm starting to believe these cables can't actually support the needs of some graphic cards @ x16 slots.
  2. Hi I'm having problems with my P3 and riser cable too. First cable caused reboots, boots with no image, driver fails warnings, and constant latency spikes and sound stuttering. Contacted Thermaltake, and got no response so far, not even a "Thank you for contacting us". I'm from Portugal, and dealt with the store I bought the case from (PcComponentes, in Spain). They sent me a new cable yesterday, which I assembled so very carefully avoiding cable strain and keep the cable curves as wide as possible. First run on new cable: same constant latency spikes and sound stuttering. GPU went back directly on the pci-e slot: all problems gone. My setup: Asus P8Z77 WS Motherboard Asus R9 390 Strix Direct CUIII Powered by a Seasonic SS-760XP I just sent an email once again to info@thermaltake.com, but I don't even get an automated reply... Saw some post before claiming the 390 is not showing much success on this riser cables. Should I keep waiting or just give up on this and try to return the case?
×
×
  • Create New...