Jump to content
  • Forum Statistics

    6.4k
    Total Topics
    42.9k
    Total Posts
  • Member Statistics

    78,903
    Total Members
    16,800
    Most Online
    Alena Anisova
    Newest Member
    Alena Anisova
    Joined

Teusxx

Members
  • Posts

    4
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Teusxx

  1. Guys, I found the solution! First when my replace arrived I tried to connect the Riser Cable. This time, my PC boot up, but after 2 minutes of gaming, the problem reappered, my GPU crashed. Forget about this “case PCI cover” (don’t know how it’s called), it’s only because my video card sucks and it curves so don’t touch PCI pins correctly. So I decided to WRAP my riser cable with 1 layer of alluminium foil. ”HEY NOW EVERYTHING WORKS FINE!!!...........WAIT A SECOND, WHAT IS THIS HORIZONTAL LINE ON MY SCREEN?” Well, I deduced was some interference with the Motherboard, let’s wrap another layer. Now it’s working perfectly, no fps drop, no interferences and no crashes. I hope u guys can solve.
  2. Guys, I can’t believe it! 12/28 my new riser cable arrived without any mail from Tt. Now my pc is booting and works, but after 5 minutes in game still crash. So I decided to wrap the riser with alluminium and now it’s working perfectly. My gpu connected directly to Mobo go to 120 FPS, with riser go to 60. But I’m very excited anyway
  3. I have the same problem.. I’m from Italy and don’t know where I can contact us.. In this case I would like to live in USA
  4. Hi guys, I'm from Italy. I sent an email with all information you want to: info@thermaltake.com (no reply received) info@thermaltake.eu (Email does not Exist) What can I do? Thanks.
×
×
  • Create New...