Jump to content

Search the Community

Showing results for tags 'driver'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
    • Memory
  • Thermaltake Gaming
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Thermaltake
    • Thermaltake Streamers
    • Gaming Chair
    • Gaming Desk
    • Thermaltake Gaming FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 13 results

  1. Hi all Just wondering if anyone is using this device. Having trouble with it. It does not appear in the BIOS as an option, (my other, external sdcard reader does), ...and from linux, it is pretty much like it is not there at all. Oh.. I can see the USB hub fine, there is no issue with that and the USB ports all work Just no card reader. Even the led does not come on when I insert a sdcard. Sent it back to the shop.. and the guy tells me that it works on widoze 10. Not sure I trust this info, since I installed widoze10 just to see - and i could not make it work So just to start, si
  2. TLDR: Disable Firewall and antivirus software. Then unplug and replug in your mouse. Then launch Command Center Pro or other respective software. Hi all. I bought Iris RGB today and had the problem. I saw many people experienced it but there's no tangible response from TT. In my case: Mouse was working. I could download the Command Center Pro v1.0012 or any other TT software and then I restarted my pc. Bluetooth & other devices in Settings shows my mouse as "Iris Optical RGB". However, Device Manager shows it as HID-compliant mouse and also as a HID-compliant keyboard somehow. Pr
  3. Hey, thermaltake and community, i just bought this challenger keyboard, and i found out that there were a driver for it. I tried to download the driver, there were no problems with the download part, but when i tried to open the driver. It couldnt. It cant open. Is there a sweetheart there can help me?
  4. I own a MEKA G-Unit keyboard and iv'e downloaded the program for it. Can't configure the macros. Please help. MEKA G Unit Config.exe
  5. Hello everyone, This is not a driver request post. This is an actual driver release/testing post. As some of you might know, TtEsports Poseidon Z keyboard does not work properly on Mac OS X. Symptoms like typing "e" generates "e ", pressing "tab" results in nothing are seen under Mac OS X. I programmed an in-kernel driver for Poseidon Z keyboard to replace the stock IOUSBHIDDriver.kext generic USB keyboard driver for Poseidon keyboard. This driver currently only supports Mac OS X 10.10 Yosemite. It's not because it uses any new features of Yosemite. It simply because I have upgrade
  6. Hi all, I have the issue with keyboard Challenger Pro. Cannot run software on win 10 (64 -bit). I have tried all compatibility modes + run as administrator, but w/t any success. The GUI even doesn't start. However, I can see the process in Task Manager. Has anyone run into the same problem? How can I fix it? TIA!
  7. I downloaded the rar file extractor and when I open the driver installer it says to connect the device. Ive tried using different ports, restarting, reinstalling. The keyboard works and can use all controls. Does the message CS:E549H mean anything? I guess I should also ask if the program is windows 10 compatible as well.
  8. Greetings, I have a level 10 M as one of the three pointing devices on my rig. Somehow I cannot find the driver for this mouse. Dont get me wrong I have the mouse software installed and running. Also I did run the firmware update tool and got a message like there is no need for update. My problem is that in device manager it shows as a default "HID compliant mouse" and in devices and printers it shows as a keyboard labeled "TT esports level 10 mouse". Sorry if this is a known issue, I have searched for "level 10 M driver" but couldnt find any relevant entries on the forum. B
  9. Hi everyone, i bought a "Tt-eSports Shock One" headset in 2015, so... today i decided to update my windows from 7 to windows10 (7 ultimate -> 10 pro). Everything is fine but i can't use correctly the headset software, i try to apply a configuration but doesnt work, the equalizer doesnt work, etc. I found the solution which is to config it manually from: "Control panel -> Hardware and Sound -> *Sound -> Manage audio devices* -> SpeakersTtShockOne/HeadphoneTtShockOne/etc -> Properties" And you need to activate all the options so you have to configure your headset manually. But,
  10. i can't run the driver, it says "please plug in gaming device to start the ap configuration" , i tried whit another usb port, tried reinstaling the driver, running as administrator, and in others pc's etc, but nothing works. but for some reason yesterday works. i have windows 10 in all the pc's by the way.. please help DDD:
  11. The app keeps saying "Please plug-in Gaming Device to start AP configuration!" but my mouse is already plugged-in. Help would be greatly appreciated. Thank you!
  12. I recently purchased a second Posideon Z keyboard when the first one I purchased for my Linux box worked so well, I had to get a second for my gaming/programming rig. Everything seems to work great on it, except when I am programming. I have a tendency to lean pretty heavy on CTRL key combinations when I work (CTRL-S, CTRL-Z, etc) and I've noticed that it appears that the key doesn't always work when used in conjunction when another key. At first I thought it was a driver issue, but now I am leaning to the idea that the ctrl key is bad. The behavior I'm seeing is that when I hit CTRL-S, rath
  13. Just bought a Saphrina mouse and I can not find the CD. Tried to find the drivers online and had 4 Saphrina drivers to choose from, picked one and installed it but when I start the driver software it says to plug in the mouse when the mouse is already plugged in. Tried reinserting with no effect. Just spent the last hour trying to get a mouse to work and get help to fix it. My last purchase of this brand was far less painful; just plug in and it works. Please bring back the DPI switch on the bottom so you do not need a driver for a mouse to work.
×
×
  • Create New...