Jump to content

BLACK V2 Owner's Club


Guest Tt Paul
 Share

Recommended Posts

Guest Tt Paul

With the BLACK V2 laser gaming mouse, Tt eSPORTS brings new life to its most time honored gaming mouse. The BLACK V2 has been improved in every which way possible. The AVAGO laser sensor has been bumped up to 5700 DPI, a new surface coating gives both a more appealing finish and comfort, new textured grip on side for better control, an additional thumb button for even more macros, and even new software/UI design & functions. The same great BLACK gaming mouse shape and adjustable weight system are maintained in the BLACK V2.

 

post-225-0-85953500-1420527012_thumb.jpg

 

post-225-0-62688200-1420527023_thumb.jpg

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...
  • 4 weeks later...
Guest Tt Paul

Thinking of getting yourself a BLACK V2 laser gaming mouse ?

The great key features of BLACK V2

  • Upgraded Avago sensor with OMRON switch
  • New Matte coating
  • Red LED illumination
  • 5 profiles with 35 programmable marco keys 
  • Life-off adjustment  software function

 

Link to comment
Share on other sites

  • 3 weeks later...
Guest Tt Josh

post-1609-0-89018000-1428652233_thumb.png


 


The BLACK V2 comes with a new software/UI, offering much improved layout and overall intuitiveness. In addition the Lift-off-distance adjustment feature is now included inside the software, instead of requiring a separate tool to adjust it


Link to comment
Share on other sites

  • 2 weeks later...
  • 11 months later...
  • 4 weeks later...

Not sure this is the right place to ask support questions, but I got one of these today and it works fine, but the TteSports command centre software is not opening. There's no error message, but if I kill all the processes in task manager and reopen it I jsut get an exclamation mark (!) appearing in the notifications for a second with no explanation. I've tried opening as admin and restarting: no luck.

 

System:
Windows 10 64 bit

Intel core i5-2400

AMD R9 390X

8GB DDR3 - G-Skill Ripjaws

Link to comment
Share on other sites

Guest Tt Josh

Not sure this is the right place to ask support questions, but I got one of these today and it works fine, but the TteSports command centre software is not opening. There's no error message, but if I kill all the processes in task manager and reopen it I jsut get an exclamation mark (!) appearing in the notifications for a second with no explanation. I've tried opening as admin and restarting: no luck.

 

System:

Windows 10 64 bit

Intel core i5-2400

AMD R9 390X

8GB DDR3 - G-Skill Ripjaws

Hi, try this software:

BLACK V2 GAMING SOFTWARE V1.0

Link to comment
Share on other sites

  • 3 months later...

Yes I have the same thing with exclamation mark (with the gui v1.0 not exist) but in event handlers of windows application says

that loaded successfully.

So confusing.

In the GUI also firmware issue is missing.

At the first time it loads the firmware from unknown location

why we do not have control downloading it or replacing with the older version in case of problems

 

my major problem is it is not working when I turn on my pc.

also I can use it inside of bios

 

but sometimes it works (rare)

Link to comment
Share on other sites

By the way second thing that is very unusual give bad feeling about the driver (v1.018) as follows:

 

If I load manually the v1.018 command center I see a yellow exclamation mark (!) in general give a notice to user something is wrong.

 

 

 

Note: Why I can not use copy/paste functionality in this forum?

Link to comment
Share on other sites

  • 6 months later...
  • Tt David changed the title to BLACK V2 Owner's Club
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...