Jump to content

(SOLVED) Proud owner of V71, but the fan controller issue is chipping on the satisfaction


Recommended Posts

I have bought yesterday the V71 piece of art and I am very satisfied with the level of customizability and the ease of how you can personalize it, BUT...


I have an issue with the fan controller. It doesn't work. I tried to find some explanations for this problem, I triple checked the connections to the motherboard but I can't figure out what is wrong. Everything else works: the reset button, the power button, USB slots, but those fan control buttons.


The workaround for the fans to work is to connect them directly to the MB, but I want to have the full experience with this Chassis.


Please help.


Thank you!

Link to comment
Share on other sites



Welcome to the Tt Community!


Quick question, did you plug in the 4-pin molex connection to the PSU?


I did. I started to check every cable that entered in the fan controller and I found that 4-pin molex hidden between the other cables. I connected it and it worked. Now I am fully satisfied by this chassis. :D


Topic solved.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...