Jump to content

Snyc issues with TT RGB Plus Software & Razer Synapse 3


Recommended Posts


I recently updated Razer Synapse 3 to Ver: 3.5.831.82315 and now the TT RGB Plus software V 1.3.7, F 2.0.3 will not connect or just crash if I attempt to connect to "Chroma Connect Enable"

I have uninstalled and reinstalled both software's but there is no fix to the issue, I have to make multiple attempts to connect to chroma before it will will finally work, sometimes after multiple crashes.

I have also noticed that the fan speeds for my Riing Plus 12 fans seem to be out of sync, I mean one fan is spinning slower then the other two. I have not noticed this until the last software updates.

I checked my connections from the power supply, to the fan controller, to the fans and all looks good there.

I think it is a Razer issue seeing as I saw all this happen with there software update and have already reported the issue to them, but there has been no response in there forum. So I figured I would go ahead and report the issue here and see if there is any info on a fix.

Sorry for the long post, this is my first issue with your fans or software so I am just trying to find a fix if possible.

Thank you


Link to comment
Share on other sites

1 hour ago, TT CPM said:


How many TT RGB Plus products you have? only 3 riing plus fans?

Does TT RGB Plus works fine? What product of Razer you trying to sync?

The Fan speed will not be exactly the same, it will be a a bit different.


I have only 3 Riing Plus fans

TT RGB Plus software crashes when "Settings, Chroma Connect Enable" then will not open again until after a few tries, but If I attempt Chroma Connect again crashes

I am not trying to sync a Razer product I am trying to sync the fans to Razer Synapse 3 so I can control the fans lights through it to match my lighting profile. It has worked before but now it is unavailable

Ok good to know about the fan speeds


Thank you


Link to comment
Share on other sites

Ok... why are you asking what Razer product I have? this is a issue with the TT RGB Plus Software and Razer Synapse 3 software, not products.

But here is all that I have on the pc

CPU: Ryzen 5 2600
Motherboard: Gigabyte B450M DS3H
Graphics Card: Gigabyte Nvidia Geforce GTX 1660 Super
Solid State Drive: PNY CS900 500GB
Hard Drive 1: Seagate BarraCuda 2TB Internal
Hard Drive 2: WD Blue 1TB
Memory: 2 of XPG Z1 DDR4 3000MHz (PC4 24000) 16GB (2x8GB)
Power Supply: CORSAIR RM Series RM650
Case: LIAN LI PC-O11 Dynamic Razer Edition Black
Headphones: Razer Nari Ultimate Wireless
Microphone: Razer Nari Ultimate Wireless
Webcam: Logitech C270
Mouse: Razer DeathAdder Elite
Mouse Pad: Razer Firefly V2
Keyboard: Razer Ornata Chroma
PC Controller: Razer Wolverine Ultimate
3X ThermalTake Riing Plus 12 Fans


All the issues started with the last Razer Synapse 3 software update

Link to comment
Share on other sites

4 minutes ago, TT CPM said:

Thank you, the reason is when we contact Razer to check the issue, they will ask us the same thing.

We will contact Razer soon see what they changed in last update, will keep you posted.

Ok that makes sense, I apologize if I sounded rude or ungrateful for the support.

Thank you for the help

Link to comment
Share on other sites


I am also having this issue and i have only just finished building my new PC. I have the Floe DX 360 and 6 Riing Duo fans, i bought them as it says they are Razer Synapse compatible.

RGB Plus keeps telling me thast i need to check that i have at least one Razer device connected or that the software is installed. I have a Raser KB/Mouse and Lian Li case connected, i even have other devices connected through "connect" similar to the TT software and yet its only the TT RGB plus thats the issue.

Other forums suggest uninstalling and reinstalling all the software and reconnecting, this worked once but is now not working..

 Please Help.




Link to comment
Share on other sites

I am also having this issue.  Just finished adding the Thermaltake Pacific CL360 Max D5 Hard Tube Water Cooling Kit to my system.  The reason I chose Thermaltake over Corsair is so that I could sync it with my Razor KB/Mouse/Gamepad.  I am having the same issue as the others.  Razer Synapse is working with the Asus connect service without issue, it is only ThermalTake that is having this issue.

I am using TT RGB Plus v1.3.7 and Razor Synapse 3.5.831.82315 on Windows 10  version 2004 (OS Build 19041.450).




Link to comment
Share on other sites

I am having the same issue for a few days now. Everything synced great before, but now the TT RGB Plus software is unable to sync up.

I use 3 TT LED strips, I have a Razer keyboard, mouse and mousepad. The MSI dragon center and the Asus sync is still working perfectly with Chroma connect. So It only seems to effect the TT RGB Plus driven LED's.

Link to comment
Share on other sites

Update - Ok Razer just put out Synapse Ver. 3.5.907.90217 that in the release notes states a fix for Chroma Connect issues, well sadly it did not fix the issues in regard to connecting to my ThermalTake fans.

So I am at a loss of when this will be corrected on Razers end. Until then it will just have to be the way it is I guess

Link to comment
Share on other sites

  • 3 weeks later...


Looks like a new issue has happened, sorry not sure if I should make a new topic or not.


So after yesterdays update that installed 3.5.930.92510 of the Synapse software Chroma Connect has not been working with my ThermalTake Rinng Plus fans. Before this last update There was no issues in connecting and syncing the lights, but now the only time they sync is if I use "Quick Effect" or "Chroma Studio".


"Chroma Visualizer" or the Program "Wallpaper Engine" used to sync the Synapse to the TT fans perfectly but now they stay locked on the previous color or just go blank completely if I try either of them.


I have attempted a full reinstall of both programs but no fix.


Current ThermalTake software is Ver, 1.3.8, F 2.0.3


Thank you for any support

Link to comment
Share on other sites

  • 2 weeks later...
On 10/5/2020 at 1:13 AM, TT CPM said:


We actually tested the update last week, it worked fine.

Our software team will contact Razer today see if they change anything after they sent the update to us.




Hi, just wanted to update the situation.

I have been in contact with Razer support and trying to find a fix for this issue.

I am not the only person posting about syncing issues in their support forums.

there are apparently many other Chroma enabled device brands that are experiencing issues after the last update.

Thank you for your support

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...