Jump to content

X1 RGB software not recognizing my keyboard


Recommended Posts

(I hope this doesn't get drowned in the wave of spam this forum has received since yesterday.)

My new Thermaltake X1 RGB mechanical keyboard is not not being recognized by the software. It just says "Please plug in Thermaltake device to get started".

I already tried to update the firmware using the enclosed "X1 RGB Firmware Update.exe" tool, which does work and even claims that the update successfully upgraded the firmware to V1.00.29, but the software still doesn't recognize my keyboard.

I'm running out of options. What else can I do? I'm running Windows 10 with the latest feature update.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...