Jump to content

Tt esports Commander mouse not working


Recommended Posts

So I purchased the Tt esports Commander mouse and keyboard bundle set about a year ago and it has been working great until the last couple of weeks. The keyboard still works fine, but the mouse will not let me click the buttoms simultaneously. For example, in a shooter, I cannot hold down the sights (right-click) and shoot (left click) at the same time. I can only hold down the sights and look, or no scope. It also does this for other games as well.


I have tried using a different USB port and nothing changed. I have not tried a different mouse yet. I also went to the device settings and couldn't find anything that would change it back. I'm also running Windows 10


Has anyone else encountered this problem?



Link to comment
Share on other sites

  • 2 weeks later...

Before suggesting all sorts of things both software and hardware related,

Please try a different mouse first.

This will tell if the problem lies with the mouse drivers, mouse hardware, with windows, or with the games..

I just tried a new mouse and it seems to work fine. 

I have read a lot of reviews about the Commander mouse not working after a few months of use, so I am assuming that is what happened.

Link to comment
Share on other sites

 Could you please contact our customer service and we will have someone help you:


USA / Canada :


Tel: Toll-Free 01-800-988-1088

M-F 9:00AM â€“ 5:30PM (P.S.T)   


Mexico :

Por Email: apoyotecnico@thermaltakeusa.com

Por Telefono: 01-800-823-2606

En el D.F: (55)5648-6715 Atencion de 10:00AM a 6:00PM (P.S.T)   


Brazil: suporte@thermaltakebr.com


Asia: cs2@thermaltake.com.tw


Europe:  support@thermaltake.de

Link to comment
Share on other sites

  • 3 years later...

Hey there,

I bought this Bundle roughly over a year ago and stopped using it for the past 7-8 months because the Keyboard broke and i got a new bundle. Ive tried using the mouse again and the lights turn on, but there is no cursor on my screen let alone the mouse not working at all. Ive used another mouse after trying and it seems to work fine, but when i go back to the TT esports mouse it still doesnt work.

any help? thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...