Jump to content

Thermaltake: Riing 12 Premium 3 pack software issue.


Recommended Posts

Hey Thermaltake,

 

I have recently purchased a 3pack of Riing 12 RGB Premium edition fans, and upon plugging them in as instructed:

Connected to the PSU directly + All Connections triple checked

 

the fans would spin and light up red, but not be seen by the controller software. 
I checked the BIOS to see if my motherboard detected the controller, it does. I checked Device Manager to see if the OS detected any issues, it does not. 
I have tried all the editions of the software I can find (v1.0.0, v1.0.1 and v1.0.2) despite v2.0.2  being alluded to on the product page (I could not find it anywhere.)

 

At the moment they are lit up red, and spinning fine, but there is no information in the software, and I'd say 50% of the time it does not 'initialize' correctly and the icon is not by the clock area. 

 

It appears this isn't a small issue, as there are posts about this all over the forum. I contacted Thermaltake on Facebook to tell them about my issues in hopes of not flooding this forum, but they have requested I post here anyway!

 

Should I just open an RMA ticket?

Link to post
Share on other sites
  • 4 weeks later...

I too have had the same problem, it's the software, not the HUB! I may be able to help you temporarily though if you have Windows 10 regular and NOT the Anniversary Update! Go find the xml file under roaming folder, if you need further advice about where that lives let me know. Once that is deleted uninstall the software, and then reinstall it! Next look for under program files where it gets installed and look for a icon called HID. Set this to Windows 8 compatibility and the software should work as good as it can for now. You're in better shape than I am because I got the Riing Plus RGB fans that just came out and the software doesn't work period. 

Link to post
Share on other sites
  • 3 weeks later...

Hi,

 

Not sure if this is resolved - but one of the issues we had with broken USB controllers was just that - no connection, only red which is default. If you can start the software and still no result after unplugging usb cable and starting anew - then may very well be busted controller.

 

Good luck!

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...