Jump to content
Sign in to follow this  
RaTtMaN

Can't get DPS G app to open after install

Recommended Posts

Hello all, new to the DPS G, just arrived and installed today, however I can't get the app to work, plugging and unplugging the cable from my motherboard does get a sound like I plugged in/un-plugged a USB device. Can't find the PSU in the Device Manager however. The app does install, it just won't open even right clicking and telling it to run the config does nothing, I get a quick popup and then boom gone. Can't register or anything to get this working.

I'm getting errors in the Event viewer for .Net when it comes to this, specifically this error

Application: DPSapp.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 00F46DE4

NetErrorPSU.jpg.d1b56c374200656b78b9dc333f39dc50.jpg

 

Here is the other error it produces

Faulting application name: DPSapp.exe, version: 1.0.0.1, time stamp: 0x584944f2
Faulting module name: DPSapp.exe, version: 1.0.0.1, time stamp: 0x584944f2
Exception code: 0xc0000005
Fault offset: 0x00026de4
Faulting process id: 0x161c
Faulting application start time: 0x01d2f06932d637f7
Faulting application path: C:\Program Files (x86)\Tt\DPSapp\DPSapp.exe
Faulting module path: C:\Program Files (x86)\Tt\DPSapp\DPSapp.exe
Report Id: d654093e-6013-43fa-ae67-2e9e35b5d903
Faulting package full name: 
Faulting package-relative application ID: 

NetErrorPSU2.jpg.895d3737bf7ae8309070f59c87746585.jpg

 

Here's the install file that I downloaded Tt_DPSapp_V2.4.2_20170208.exe

Current system is below:
AMD Ryzen 7 1800X OC'd to 4.1Ghz

Corsair Vengeance 2666Mhz LED

AMD RX 480 that's bios has been updated to a RX 580 (so drivers installed are RX 580)

ASUS Crosshair VI Hero RGB LED motherboard

Windows 10 Pro version 1703.

.Net Framework version of Windows 10: 4.7 with 3.5 also enabled.

PSU Model Number is TPG-1050D-G this is the Tough Power DPS G 1050 Watt.

 

Also included some error screen shots, thanks for any assistance! I just want my new toy to work!!! :(:(:(:(

Share this post


Link to post
Share on other sites
2 hours ago, Denny said:

Hi,

Can you please upgrade to the latest version,V 2.4.3333?

here is the download link:

http://www.thermaltake.com/dpsappdownload.aspx?type=dpsgapp&lang=global

please let me know if you still have troubles in the installation.

I'm downloading it and trying it now, thanks for the link! I'll update this with the status after the update

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...