Jump to content

Problem launching DPS G Ap p2.0

Recommended Posts

Hello everyone,

I am having a hard time launching the DPS App on my Windows 7 Ultimate 64bit. Everytime I launch the programm it tells me to install Adobe's Flash Player. However Flash, Java and .NET is already installed on my machine. These versions are installed:

Flash Version:

Java Version: 8 Update 131

.Net Version: 14.0.23026


I already tried multiple time to reinstall the app, flash, java and .NET. I alos tried to install and launch the programm as an administrator with the same results. UAC was already deactivated. The psu is a Thermaltake Toughpower DPS G RGB 850W Gold. From the official Thermaltake support I haven't got any answer.. =(


Someone knows how to fix this issue or what more I can do or test



Thanks in advance for helping me out 



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...