Jump to content

Riing Software and Ryzen 1700 issues!


Recommended Posts

Hey Everybody,

The long and short of it: RMA'd the control box, dealing with the same issues (pictured). 


What I've tried:

-Connecting to every USB port: directly on mobo, case front panel, and back of mobo. I restarted my comp each time I tried a new usb port. On the attached image, bottom right corner, I do see system Temp/IP address (removed) as well as all of my system specs after clicking the "Info" icon...

-The mobile app (via usb cable) can connect, however can't make any changes. 

-Several versions of the Riing Software: 1.1.3, 1.1.2., and 2.1.5. Some didn't load, some presented the same error code pictured, some got past the error code however can't make changes. 

-I've tried installing the Riing software w/o the control box powered/connected to mobo, CCleaner'd any registry errors, restarted - no luck. 

-I've tried connecting the control box to another computer, Surface Pro, same issues.

(Fresh install of Windows, yesterday)

(BIOS and drivers updated today, details below)


I do have an available RGB header on my mobo. Is it possible to bypass the control box and just use the software I'm currently using for mobo and cpu (Ryzen Spire)?


Open to all suggestions.


My Specs:

-MOBO GA-AB350N (BIOS:F6a, most current) 

-USB Drivers updated via "AMD Software" (ver: 16.50.2601)

-Ryzen 7 1700

-Zotac 1080ti 

-Windows 10 Home x64 (10.0.16299, Build 16299)






Link to comment
Share on other sites



Thanks for the information. First thing to mention, please contact our support again about the recent RMA you did with us, will take a look.


We can test the controller before it ships to help with the troubleshooting.

Also, with the "other systems" you used. When you connected the controller to another system, like for example a laptop, install the software on the laptop, does it work?

This would require you to use a Micro USB to USB cable, like for your phone. Give that a try if you can, if it works there it could be a compatibility issue.

We can help with replacing the controller and just let the support rep know what is going on.

Link to comment
Share on other sites

Hey Mike,

Thank you for the response.

Yep - I connected the box via micro to reg usb. The surface pro I used did not respond to the 2.1.5, nor did an Intel-based laptop carrying Windows 10.

Perhaps I fried it when I first connected to my AMD platform? I followed protocol: using a dedicated line from my ps and connected when the system was off.





Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
  • 2 weeks later...

Hi Duluth,

Apologize for the delay with my reply, since you are located in the USA, please contact our USA support so we can setup an RMA to swap it out.

Please also let them know about the situation and talking with me so we can help test prior to sending out.

If there is any update, please let our support know.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...