Jump to content

Poseidon Z RGB firmware at 0


Recommended Posts

Windows 7 64 pro
Brand TT eSports
Model POSEIDON Z RGB (Brown Switch Edition)    


When first connected, the lights came on all red and worked.
After the FW update,  no lights, no keys work.

Connecting keyboard responds, slowly, but updates devmgmt with new HID device.
When first connecting (to a new USB port), it shows "other hardware" TT eSports Keyboard, but when it finds the driver, it's listed as a HID.

The 1311 installer says firmware at 0, wants to update to 36, says it finished update, but still says 0.
The V30 updater says firmware at 0, wants to upate to 30.
Both process, show 'finished' and then nada.

Tried Uninstall, disconnect keyboard, install again, reboot, update, reboot, update, reboot update.
Tried rebooting with keyboard connected and with it disconnected.
Tried FN-ESC, no response.

The OSD software seems to work but does not setup anything, no lights, no keys work. 

When not connected, it says WARNING Please plug-in the Gaming Device to start the AP configuration !  [YES]
Tried redownloading the installer files.
Verified the install folder was removed when uninstalling.
Disconnected the other keyboard, to make sure it wasn't somehow interfering, but I did have to connect it to logon, then disconnected it, then connected the Z, then ran the install.... didn't help.

Also, my Blue Switch works.  I just connected it again and it came right up, lights on, keys respond.... maybe this is brown is bad?

Is there a trick to getting this working?

Link to comment
Share on other sites

  • 5 weeks later...

I was able to update the firmware on the other PC, first try.

I did the 0 -> 30 update first, then installed the latest software and did the 30-36 update.

Without reconnecting the keyboard, it worked fine.


Moved to this pc, working fine here.

I am having a similar issue with mine, only difference is I have the blue switches…


How were you able to get the 0 -> 30 firmware installed? Mine just sits and sits, never moves an inch.

Link to comment
Share on other sites

I did a lot of reinstalls and reboots while working on it, it was really annoying.

The issue I had was that it would say it completed the update, but it was apparently not really updated.


On the other PC I had not installed any Thermaltake keyboards, probably no special keyboard drivers/installers were ever installed on it.

I installed just the 0>30 updater first, and it worked.

Then I did the other one.


There are several possibilities...

Windows drivers are complicated, and prone to issues due to the constant OS updates, interference from other settings and drivers, variations in USB controllers and hardware...

It could be that the installer is unable to update a file that exists already, which is why I did the 30 update before installiing 36.


I read a lot of things which made no obvious difference....

1) Disconnect the keyboard.

2) Uninstall all the thermaltake stuff

3) Reboot

4) Install 30 drivers

5) Connect keyboard ( use a USB port you have not used before)


Try yet another computer.

Try going to a restore point in windows.

Make sure all Windows updates are on automatic and updated.

If you have having any other issues with the PC, could be related...

Check the event logs, application and system.

Use the FN-ESC reset.


I did all these things because they work sometimes when installing hardware.

But when I connected it to the other PC, it worked first try.


Also, I did the 30 then the 36 and it worked, but it may have worked on that other PC if I had gone right to the 36 fw.

I can't say what exactly resolved my issue, there's multiple variables....

And my issue was a little different.


Be sure to contact Thermaltake support, too, they may have more info.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...