Jump to content
Erasmus_Tycho

Riing Plus RGB Control Software

Recommended Posts

First, let me just start by saying that these are really solid fans. I like how they only have one single cable, not two coming off of them like a lot of other brands have on their RGB fans. That said, I have a few suggestions I'd like to make.  

Here's my system for reference:
uBFBsGz.png

 

Ryzen 1800x

16 x 2 G.Skill RIPJAWS (3200 14CAS)

ASRock x370 Taichi MOBO (BIOS v4.4)

EVGA 1080Ti K|NGP|N Hydro Copper

Corsair HX1000 PSU

3 x 120mm Riing Plus, 3 x 140mm Riing Plus, 2 x 200mm Riing Plus

TT RGB Plus software version 1.2

Windows 10 Professional (64bit)

 

Two controllers, first controller is setup with Rear exhaust in position 1, top rad fans in position 2, 3, front intake fans set to 4 and 5.  Bottom radiator fans are on the second controller in positions 1 - 3.

Controllers are setup appropriately with the second set to position 1, colors chain and allow customization across all 8 with no problems.  The biggest issue I have is the fan speed controls.  if I set the rear exhaust fan to silent mode and disable PWM then switch to controller 2 and set position 1 to performance, the software crashes.  Sometimes, the software overrights.  So if I set the bottom 1-3 to performance, switch to first controller and set rear exhaust to silent, if I go back to the second controller, the fan in position 1 is running at silent instead of performance.  It's like I have to go back and for several times before I can get them to accept the changes.

Also, what's with the round robin user interface?  I'd prefer to have all 5 of my fans per controller available from the windows UI without having to click through them to get from the front to the back. Finally, before I forget... it would be wonderful if we could define what temperature reading causes the fans to ramp up in PWM mode, it would be even better if we could define our own custom fan curves!

Thanks for reading, these really are great fans, I just want to get the most out of them.

 

Share this post


Link to post
Share on other sites

The TT RGB plus software version 1.2 does seem to be having crashing issues related to PWM toggles. As for the going back and forth are both controllers using the same profile? 

Share this post


Link to post
Share on other sites
1 minute ago, Tack said:

The TT RGB plus software version 1.2 does seem to be having crashing issues related to PWM toggles. As for the going back and forth are both controllers using the same profile? 

No, one of the profiles is in the default position, while the other is in the 1 position as per the instructions.

Share this post


Link to post
Share on other sites

MMM if you have them set to different profiles in the software and its still doing that I would see if reinstalling the software fixes anything. I just went from 1.2 then 1.1.8 then back to 1.2 and I no longer crash on PWM toggle. So its worth a shot if you have already tried this I would hit up support and give them a call.

Share this post


Link to post
Share on other sites

Hello,

If you are having issues after updating with the software, please uninstall, delete the folder where the software is located and do a fresh install. 

Version 1.2.0 is on our website now, we are working on some updates as well already from feedback, so keep eye out for next update.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...