Jump to content

120mm rgb pure software stopped opening

Recommended Posts


I bought a thermaltake pure rgb fans 120mm .. and it was working fine then suddenly the software stopped opening and am stuck on the same color and  speed and its a bit noisy.. how can i fix this,? I reinstalled software a couple of times and changed slot inside the motherboard usb but still nothing is happening.. help please

Link to post
Share on other sites

I think I may be having the same issue. When I try to run the software, it appears in my task manager as well as my task bar for a quick second and disappears, before even fully opening.

I have tried reinstalling older versions of the software, full admin privelages, safe mode, disabling anti-virus, unplugging the controller - everything. Nothing works!

I will keep trying to find a solution but any help is greatly appreciated.

Specs are: Windows 10 x64, Intel i7 4790k, AMD RX Vega 64

Link to post
Share on other sites

It was working fine and i like the fans but now its annoying because sometimes i dont want the light when iam watching a movie.. i click and nothing .and the speed theyre at is relatively noisy . iam waiting for a reply because i can return them via amazon but i need to make sure i tried everything and so am waiting for a reply from thermaltake

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...