Jump to content
Serjo77

DPS G APP S\N invalid or has been bundled by other user!!!

Recommended Posts

Hello!
I have a problem when registering the serial number in the dps g app 3.0 program (PSTPG0750DPCGEURLK000200) of the Thermaltake Toughpower DPS G RGB 750W Gold power supply.
When I enter my serial number, the dps g app 3.0 program gives the error "
The number you have entered is invalid or has been bundled by other user."
Please give me the correct serial number, not occupied by anyone!
Why buying your product, I can not use all the functions due to your broken serial number registration system! ?????

I have already written two times to your technical support, the answer never came, although more than 24 hours have passed!
Sorry for my english it is very bad! as your registration system of S\N!!!!

RAI1F-A6zhM.jpg

f4RtQfo77tE.jpg

rg4ccZyxdUA.jpg

Share this post


Link to post
Share on other sites
On 1/14/2019 at 12:57 AM, JeffWu said:

I sent a mail for you, please check. 

Thank you!

Hello can you please help me out too I am having his same problem been a month now and I cannot use the app because it says the same msg about the s/n being bundled with another user or to contact support 

image.jpg

Share this post


Link to post
Share on other sites

Hello can you please help me out too I am having his same problem been a month now and I cannot use the app because it says the same msg about the s/n being bundled with another user or to contact support 

Share this post


Link to post
Share on other sites

I am getting the same SN error as above. It says I need to register SN first.  When i go to do that it tells me that it was part of a bundle.  I have tried the DPS Fix Tool but it does not fix the issue.  I have DPS online account already working.

Can you email me at sherief.singer@gmail.com

 

Thanks

Share this post


Link to post
Share on other sites
On 5/24/2020 at 12:35 PM, ILMGuy said:

I am getting the same SN error as above. It says I need to register SN first.  When i go to do that it tells me that it was part of a bundle.  I have tried the DPS Fix Tool but it does not fix the issue.  I have DPS online account already working.

Can you email me at sherief.singer@gmail.com

 

Thanks

Hi sir

 

Could you provide your SN number?

I'll check with our database. Thank you!

Share this post


Link to post
Share on other sites

Hi,

i am having similar issue with the S/N. i have downloaded the fix tool and yet im getting the same error. im afraid that someone might have used my S/N number from the box.

is there a possibility that my problem can be fixed?

i have toughpower irgb plus 1050w platinum power supply and my email address is: Ram_db@yahoo.com.

Thanks.

Share this post


Link to post
Share on other sites
On 6/19/2020 at 9:39 PM, Ramtin_db said:

Hi,

i am having similar issue with the S/N. i have downloaded the fix tool and yet im getting the same error. im afraid that someone might have used my S/N number from the box.

is there a possibility that my problem can be fixed?

i have toughpower irgb plus 1050w platinum power supply and my email address is: Ram_db@yahoo.com.

Thanks.

For those people like me who didn't know about this, you need to dial in the rest of the serial number and not the full serial number nor only the first part of it. check the S/N mentioned in the APP and then dial in the rest of the S/N.

Hope this fixes your issue with S/N not registering.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...