Jump to content
Psycho95

TT X1 UK layout SW light problem

Recommended Posts

Hi 

I have a problem with a tt x1. I have a uk layout and i have a different keys in X1 RGB soft. When i press the button witch is not on that position in SW a whole SW stop working. 

Can someone help me solve this problem ? 

I upload a video on youtube where you can see it. 

Thank you for any help :) 

Share this post


Link to post
Share on other sites

That is quite weird, I'm thinking it's due to the layout of the keyboard compared to the software, it should be cross compatible though. I would recommend that you contact Thermaltake on this one and request that they include the UK layout in the software. In my eyes that is a little bit lazy of them of them not to include the UK layout in it.

Where did you download the software from, try to find a UK website, if they have one. If anything, I recommend that you ditch the software until it gets better, it is extremely buggy and I find that I prefer the keyboard shortcuts. (Maybe just me ;))

I hope you find a resolution to this issue!

-Cynaax 

PS: Nice setup

Edited by Cynaax
Had to add something

Share this post


Link to post
Share on other sites

They dont have a UK website :( so i have a SW from global webpage.  I send them a help request but i dont think someone help me. I send them in a past 2 request about riing fan. No one reply to me :( but TT have a great community so they help me on forum :) 

So i try to wait if they reply and try work on just a keyboard shortcuts. 

Share this post


Link to post
Share on other sites
On 5/6/2019 at 10:03 PM, Psycho95 said:

They dont have a UK website :( so i have a SW from global webpage.  I send them a help request but i dont think someone help me. I send them in a past 2 request about riing fan. No one reply to me :( but TT have a great community so they help me on forum :) 

So i try to wait if they reply and try work on just a keyboard shortcuts. 

That's very weird that they don't have a UK styled driver, even a UK registered domain. They have an Australian domain where I got my drivers from. Also I would urge you to use the keyboard shortcuts, the software is very buggy in my opinion, it's clunky and constantly crashes.

In my case they also took a while to respond, max was a week and that was for a keycap replacement, which they happily helped me with. +Rep to TT Australian support. I would urge you to send them a message on Facebook, as they have a Facebook for the UK market. Link: https://www.facebook.com/ThermaltakeUK/

Hope this helps! If you need any more help, quote this reply and list the problem below. I'll he happy to help!

-Cynaax

Share this post


Link to post
Share on other sites

I have some news (bad news for me :( ). I contact TT on FB and they say me to send a keyboard to service :( thats bad because i live in czech and shipping cost more than 1/3 price of keyboard...... ####. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...