Jump to content
Umina323

Does anyone have TT RGB Plus software 1.2.7 or Earlier!?!?! PLEASE!?!?!?

Recommended Posts

So I have a custom water cooled gaming computer, in which I chose to use 7x thermaltake Riing+ RGB Fans, Thermaltake RGB LED's, and RGB controller. I was very happy with my setup, until the TT RGB Plus software auto updated itself to 1.2.8 and started causing issues for me.

I get huge network lag spikes (3+ seconds - Yes, 3000+ Milliseconds) when the software is running about every 5-10 seconds. It makes using my computer online choppy and laggy. I can't play games or stream videos or do anything it is so bad... Until I close the software, and then everything is fine. I have tried a fresh install of windows - SAME THING. Not sure what happened, or if there is some kind of incompatibility with my particular computer or whatever, but... This is unbearable. I am forced to disable the software when gaming, and deal with a dancing rainbow PC and no fan speed modulation. The issue seems to have appeared when thermaltake switched to 64-bit software.

The old versions of the software worked fine for me but I never saved the old downloads and for the life of me I can't find a link anywhere online.

Does ANYBODY PLEASE Have a copy of the 1.2.7 or earlier version of TT RGB Plus!? It would literally save my gaming experience and my sanity. I'm very upset having spent almost $400 on fans and lights and having to deal with this and getting no help from thermaltake themselves (Yes, I have tried to contact them!!!) Did anyone save the old download and can be my hero!!?!?!?

 

Share this post


Link to post
Share on other sites
On 7/1/2019 at 1:24 PM, Teszty66 said:

Teszty66 YOU ARE MY HERO!!! I downloaded and installed the v1.27 and my problem is solved. 

I honestly can't thank you enough. You have literally restored my sanity and brought back my love for my PC. You have made my week. Thank you so much, man.

Share this post


Link to post
Share on other sites

I had the same problem... took me a week to figure out that it was this software that was driving me insane. I am gonna start saving these installation files from now on !

Thanks guys.

Share this post


Link to post
Share on other sites
4 hours ago, kourathi said:

any chance of reuploading 1.26 please?

so far no version works without that crappy latency.

 

I just checked the links above from teszty86 and both the 1.26 and 1.27 download links are working.

1.27 worked for me though... For whatever reason it was when the software switched to x64 that caused my problems, and 1.27 is the last x86 version.

When I was troubleshooting I simply opened a command prompt window and ran a "ping -t" test (continuous ping test) to my router (if you don't know your router's IP run "ipconfig" and write down the IP address shown under "default gateway"). For me it was "ping -t 192.168.1.1". This showed me the responses "2ms - 2ms - 2ms - 2ms - 3029ms - 2ms - 2ms - 2ms - 2718ms - 2ms" and would just repeat these huge lag spikes every 5-10 seconds. Then you can close programs one by one until the lag stops. For me, it was the Thermaltake software.

I was specifically testing the ping to my router because I didn't want issues with the internet connection to be a variable. The lag that I was getting was system-wide and affected all networking on my PC. If the ping to your router is fine and you're still getting lag in games, your issue may be elsewhere. 

-Dave

Share this post


Link to post
Share on other sites
10 hours ago, Umina323 said:

 

I just checked the links above from teszty86 and both the 1.26 and 1.27 download links are working.

1.27 worked for me though... For whatever reason it was when the software switched to x64 that caused my problems, and 1.27 is the last x86 version.

When I was troubleshooting I simply opened a command prompt window and ran a "ping -t" test (continuous ping test) to my router (if you don't know your router's IP run "ipconfig" and write down the IP address shown under "default gateway"). For me it was "ping -t 192.168.1.1". This showed me the responses "2ms - 2ms - 2ms - 2ms - 3029ms - 2ms - 2ms - 2ms - 2718ms - 2ms" and would just repeat these huge lag spikes every 5-10 seconds. Then you can close programs one by one until the lag stops. For me, it was the Thermaltake software.

I was specifically testing the ping to my router because I didn't want issues with the internet connection to be a variable. The lag that I was getting was system-wide and affected all networking on my PC. If the ping to your router is fine and you're still getting lag in games, your issue may be elsewhere. 

-Dave

Hi

Regardless of which links i try to download theyre all for 1.27. When you mouse over the links you can see theyre all for that one version. :(

The latency isnt internet related its DPC latency that the TT software is creating ie: stutters in video, music and games.

I've pinpointed it down to the TT software. When I run latencymon with no TT software running there is zero dpc interrupts, soon as i load up TT software it sky rockets.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...