Jump to content
Sign in to follow this  
Federico

No reply from support

Recommended Posts

I have problem with the power supply my friend bought for me:

1 it didn't had modular sata cable in the package

2 after getting the cables by asking the europe support and one moth of waiting, got 2 500GB HD burned when i attached them to the power supply.

I have opened an eRMA on the site, but after the first reply the 15 of august i didn't get any more information from the support?

What i have to do? start to think that 7 years warranty wrote on the box is because the support need 7 years to reply to customers?

This plus the riser cable of my Case Thermaltake Core G3 that kill my GTX 1070 performance let me think i have to stop to buy Thermaltake product.

Share this post


Link to post
Share on other sites

Hi Federico

Sorry about what happened.

I have contacted our customer service here from the headquarter and help you out quick.

Please use this window from now on : cs3@thermaltake.com.tw

Best regards

Share this post


Link to post
Share on other sites

Hi Joshua,

thank you for your replay, i didn't got any email informing me that you replied, so i'am sorry to reply you just now.

I have just sent the information about the eRMA i had opened in the european support site to the address you specified , i hope someone will replay me; i will update the message when i will get the support.

Thank you

Federico

 

Share this post


Link to post
Share on other sites

I have on of the 1000W PSU and installed the DPS app on my PC which went decently but unfortunately this was all part of a new system build and I had to create a new user and migrate things to it.  The DPS G app now launches and creates a try icon which goes away as soon as I mouse over it.  If I return to the old user profile by signout/on, it comes right up.  Tried a full uninstall and reinstall and the only profile it works on is the old one I don't want.

The event log gives an exception in module QtCore.dll, code 0xc0000005.  No I've tried all the tricks I can think of but can't get this to work properly.

 

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×