Jump to content
Mapantz

Riing Plus Premium TT Bugs/questions

Recommended Posts

So, I finally bit the bullet and bought the Thermaltake Riing Plus 12 RGB's - triple pack. Very easy to install and set up. The software drives me a bit mad though, sometimes bits work, sometimes they don't. For example, if I set fan 1, 2 and 3  to 'Sound_control_3' I can change between single and RGB on fan 1, but I cannot do the same on fans 2 and 3 - makes no sense!

Also, how does it get the temperature? Sometimes the temperature shows, other times it doesn't. Also, what is going on with the font? The degrees characters are all messed up.

Untitled.png.cc0dea5de7daff19726f4e9aa37528c9.png

Why is it I cannot find anywhere to by a single one of these fans? I needed 4, but I could either buy 3 or buy 5. I have no room for 5, but needed one more to fit on a radiator.

If these fans are supposed to be up to 1500 RPM, how come I cannot go past 1300?

Lastly, what is going on with the Android app software? Every single review says exactly the same as what happens to me. My PC shows in the list, as soon as I click it, the app crashes and shuts down.

Fix this!

 

Edit: Just been messing around with the settings, and a load of light modes have gone missing. The radar, snake and a couple of others have all gone. How can software behave like this?

Share this post


Link to post
Share on other sites

Hi,

Thanks for posting up, I am from the USA office so I will do my best to give you some assistance.

1. You should use copy color for the light mode for fans 2-5 so they can sync to the same thing and all you have to change is just fan 1 as part of the feature. Do not forget to save either once you set the new value or the next time you reboot it will default back to previous.

2. The temp reading has been an issue we are trying to resolve. Please also update to version 1.1.3 and check (On our Website)

3. Fan speeds will vary, they can go above 1500 too, from your pic, turn off PWM and select performance that is how you max out the fan speed. With PWM on, it will still be PWM controlled based on the pre-set table built into the software.

4. Single fans are coming to other regions, but I am not sure as to when, we current sell single packs on our Global TT Premium Store:http://ttpremium.com/product/riing-plus-12-rgb-radiator-fan-single-fan/

5. I have not see the features disappear like you say, update to the latest version and and test again.

6. As for the Android App I will ask our HQ about it, I currently use it on iOS and it works fine.

 

PM me if you need any further assistance, maybe something is defective, happy to help.

Share this post


Link to post
Share on other sites
20 hours ago, ThermalMike said:

Hi,

Thanks for posting up, I am from the USA office so I will do my best to give you some assistance.

1. You should use copy color for the light mode for fans 2-5 so they can sync to the same thing and all you have to change is just fan 1 as part of the feature. Do not forget to save either once you set the new value or the next time you reboot it will default back to previous.

2. The temp reading has been an issue we are trying to resolve. Please also update to version 1.1.3 and check (On our Website)

3. Fan speeds will vary, they can go above 1500 too, from your pic, turn off PWM and select performance that is how you max out the fan speed. With PWM on, it will still be PWM controlled based on the pre-set table built into the software.

4. Single fans are coming to other regions, but I am not sure as to when, we current sell single packs on our Global TT Premium Store:http://ttpremium.com/product/riing-plus-12-rgb-radiator-fan-single-fan/

5. I have not see the features disappear like you say, update to the latest version and and test again.

6. As for the Android App I will ask our HQ about it, I currently use it on iOS and it works fine.

 

PM me if you need any further assistance, maybe something is defective, happy to help.

Hi Mike

Thank you for taking the time to reply, I really appreciate it.

#1 It's looking like a bug to me. I did what you said, I put Fan 2 and 3 to  'copy color' and put Fan 1 to Sound_Control_1, and I could change between RGB and Single. If I then change any of the settings, and then go back to the settings of what I have written ^ Above, I cannot select between RGB and Single. If I then change to random settings again, then go back  and put Fan 2 and 3 to  'copy color' and put Fan 1 to Sound_Control_1, it works again. It is basically working intermittently.

#2 I've just this minute updated from 1.1.2 to 1.1.3 - thanks for that. :-)

#3 You're right about the RPM! I set them all to PWM and then stress tested my machine, and they actually got close to 1600RPM - so that's all good!

#4 I think I may be able to get them via ttpremium.eu as i'm in the UK.

#5 I'm not sure what happened, but I had modes  snake/radar at one point, but it seems that you've actually renamed them according to a reply I read somewhere else. (Phew)

#6 On Android, the app opens normally, and I see my machine and IP, but as soon as I click it, the app crashes and closes, unfortunately.

Out of interest, i'm looking to buy the Floe Riing 240, I presume I could connect the two fans to the controller I already have (2 spare fan ports available) and then daisy-chain the second controller, and the pump connects to that?

Once again, many thanks for the reply.

Kind regards.

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the reply. Keep in mind that not all "modes" support RGB options and only single color options with the animation from that specific mode. Basically you will see the RGB option greyed out if it is not supported.

Please check with our other ttpremium.com sites, we are also working on a single fan retail pack, you might see that sooner. They are in the works already.

For the Android app, I found the issue and we are working to update it. The issue is the mobile version is not compatible with the laterest version of the PC software. We should be updating the Android app on google play store by next week, so look for that update and try it with the 1.1.3 you now have (Let me know how it goes)

For the AIO, yes, it has 5 ports on the controller and 3 will be used for the AIO fans + Pump so you have 2 extra spots there to use for whatever :)

Anything specific issue wise with the riing software, help take a simple video and post it up (really helps) and we can review it and try to recreate.

 

 

Share this post


Link to post
Share on other sites

Apple iOS App crashes as well. As soon as I connect and select my computer it crashes the app. It worked the very first time I connected the app to my pc, now all I get is crashing every time I try to launch it.

Edit : I played around with the software and I've found that if I switch profiles using the iOS app it will crash the app. I have to completely exit the software, fire it back up and then I can use the app again. However I really can't do anything within the app because if I change settings it crashes again. Please fix this.

 

 

Share this post


Link to post
Share on other sites
On 10/15/2017 at 11:14 AM, 707Snipe said:

Apple iOS App crashes as well. As soon as I connect and select my computer it crashes the app. It worked the very first time I connected the app to my pc, now all I get is crashing every time I try to launch it.

Edit : I played around with the software and I've found that if I switch profiles using the iOS app it will crash the app. I have to completely exit the software, fire it back up and then I can use the app again. However I really can't do anything within the app because if I change settings it crashes again. Please fix this.

 

 

Hi,

Are you running iOS 11 with the recent upgrade? Did it work before you updated?

I have used it for a while now on iOS without a problem. (Have not updated to iOS 11 on my phone, hope to get the iPhone X soon)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×