Jump to content

Firmware Thermaltake Water 3.0 Extreme

Recommended Posts

I bought a Thermaltake Water 3.0 Extreme cooler yesterday, and I am very pleased with it so far, but I have a question. The Fan Control Software that came with it was version 1.0 so I looked online and found and downloaded version 1.6. Now here is my question, the software tells me the firmware is version now after looking at the program folder there is a sub folder called Firmware and the version in there is Firmware_v06.HEX, how do I update the cooler to that newer firmware version?


Thank you,



Share this post

Link to post
Share on other sites

If you did NOT UNINSTALL the software before updating, this may be the reason why.
Here is a Direct link to Thermaltake for the cooler which is a setup.exe

See if Uninstalling the software, Then deleting the softwares FOLDER it was in ect. and finally installing the link below will fix it.
Other than that all I can say is wait on TT to respond, as it may or may not be a issue and the firmware was just misnamed after installation from the installer.


Share this post

Link to post
Share on other sites

Thank you for the information.


Here some information that maybe use full to Tt Staff's this is a post from Tomhardware's web site.


 steve47co1 said:


Well, I have another issue............I was able to download the fan control software from Thermaltake's site after few tries (404 errors) and it installed fine. I also d/loaded Open Hardware Monitor .6 beta and installed it, but still no cpu temps in the fan control software. Any new clues on this? AIDA 64, Core Temp, and CPUID CPU-Z all show cpu temps, but neither Open Hardware Monitor nor Fan Control Software do.


My response:


If your using the 1.6 Fan Control Software, replace the Open Hardware Monitor 0.6.0 Beta with the older 0.5.1 Beta. Just download the 0.5.1 Beta and unzip, then copy all files and paste back in to C:\Program Files (x86)\Thermaltake\Fan Control Software\OpenHardwareMonitor


Restart your computer and you will see CPU temp. Don't know why the 0.6.0 Beta is failing with the 1.6 Fan Control Software but this work around worked for me.


So at least some people the Open Hardware 0.6.0 and 1.6 Fan Control Software do not work together and Open Hardware 0.5.1 and 1.6 Fan Control Software  do work just fine together.


I'm using Windows 8.1 Pro all updates applied and Motherboard is Asus Model M5A99FX Pro R2.0


Hope this is use full



Share this post

Link to post
Share on other sites


Do you know if you are going to update the Thermaltake Water 3.0 Extreme software?

In Windows 10 it does not work.


What do we say in the comments of version 1.6? The open hardware fan with the hardware monitor open? 0.6.0 can use the most current 0.7.1 and it works well. This version 0.8.0 but it does not work either. - Use the translator to write this. regards

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now