Jump to content

Thermaltake DPS G software not opening v3.1.1. Global?

Recommended Posts

Hi Guys,

I've got the Thermaltake tough power DPS G 750W power supply. I've recently downloaded and installed the latest TT DPS G App version 3.1.1. global. However once I've installed and try opening it, nothing will open but it does show up on my task bar. omegle discord xender When i try hovering over it the icon disappears and nothing opens. Does anyone else have the same problem and is there a fix to this? I've tried downloading and reinstalling the app again three times and still the same result.

Link to post
Share on other sites
  • 4 months later...
  • 7 months later...

Thermaltake extreme force DPS G 750W force supply. I've as of late downloaded and introduced the most recent TT DPS G App form 3.1.1. worldwide. Anyway whenever I've introduced and take a stab at opening it, nothing will open except for Bazoocam it appears on my assignment bar. Presently Chatiw I can rest around evening time at long last. Does the world truly need another RGB no one can see. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...