Jump to content

TT DPS G App 3.3.1 not opening (closes automatically after splash screen) [FIXED]


Recommended Posts

I just received my new computer with a Thermaltake Toughpower iRGB PLUS 750W Gold.

After installing the SO, I downloaded and installed the TT DPS G App 3.3.1 from the TT webpage, but it closes right after the splash screen.

I managed to get a previous version (3.2.6) from another post in this forum and it works well, but it keeps updating to the 3.3.1 as soon as I start it, so I go back to the beggining. Also, both the CPU (i5-11600K) and the GPU (RTX 3070) are shown as not supported in the PC Info tab.

Is it the App's problem? Or something wrong with my computer? Is there any way to get another version (say 3.3.0) while I wait for the next? Is there any way to prevent it from checking for updates?

Thank you in advance for your help.

Link to comment
Share on other sites

  • GCGreenmoot changed the title to TT DPS G App 3.3.1 not opening (closes automatically after splash screen)
  • GCGreenmoot changed the title to TT DPS G App 3.3.1 not opening (closes automatically after splash screen) [FIXED]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...