Jump to content

X1 RGB - Please plug in Thermaltake device to get started


Recommended Posts

Just bought a X1 RGB keyboard.  Running Win10 build 1809, Asus TUF Z370-Pro Gaming motherboard, i7-8700K CPU.

I installed the TT RGB software version 1.9.0.  Even let it update to 1.9.1.

In any case, I get the message 'Please plug in Thermaltake device to get started.'  I've tried different USB ports, rebooted, etc., but still no luck.

Interestingly, Device Manager lists the keyboard as a 'HID Keyboard Device.'  I've tried various things to see if it would run a TT-specific driver, but no luck.

I also find it interesting that TT software download was unsigned.  Not sure if there might be a side-effect from that.

Any suggestions for how to get this to work?  I really like to keyboard, but will have to return if I can't get the most out of it.

Link to comment
Share on other sites

I've recently contacted support on this one, try following the steps in the pdf I attached, then try using the software (after you have successfully updated the keyboard, I would say unplug it, turn off your device, plug it back in and then turn your device back on) .

If nothing works try emailing them over at https://www.thermaltake.com/corporate.aspx?t=4 you will have to either call or email the country in which you reside in so that you can get optimum support over your issue

By the way, do not remove the keyboard when updating the firmware, this will brick the keyboard and it will not be usable at all.

Thank you and have a nice day or night



P.S. It is most likely the new Windows version, in this case they need to release either a fix or a new piece of software all together to address this issue, if you have Facebook, try contacting them on messenger as well, they responded very quickly to my issue. 

Link to comment
Share on other sites

  • 2 years later...

Hello guys, I also am experiencing some issue with the Thermaltake X1 keyboard software. What I did was to install the X1 RGB software first then head over to windows setting>devices>Bluetooth and other devices, then click on the "TT" and click remove device. After this, your keyboard will become disabled, immediately do a reboot on your computer. Then afterwards open the X1 RGB software first thing after start up, the software should now be able to recognize your TT X1 keyboard. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...