Jump to content
Wandererqq

Thermaltake 360 Floe Ring 360 Premium pump issue

Recommended Posts

Yes, the RPM adjust to the actual CPU temperature - in your case 40C the pump should run ~1300 rpm idle and under stress go up to ~1700 which usually is sufficient to keep the stressed CPU under 70C all provided your in-case temperature is no more than 5C higher than room temperature.   

Perhaps post a screenshot of TT RGB plus - lets see what's the temp display is there?

Share this post


Link to post
Share on other sites

Not sure what is going on but comparing your CPU voltages (under stress) I have same CPU  ~1.2v (value) while you on ~1.4v which is quite steep

My package temperature under stress is ~60C

Perhaps try resetting to system/bios defaults and see?

Clipboard01.jpg

Share this post


Link to post
Share on other sites

I'm using a kinda aggressive XFR profile when all cores are needed vcore is around 1.37 while there are less core needed it's going from 0.75 to 1.45. My main issue that the pump according to HWmonitor isn't running at max speed as per manufacturer description and I don't have any idea either it shows the half of the actual speed or the pump runs at half speed actually. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...