Jump to content
Sign in to follow this  
Avenger86

iRGB PLUS 1050W noise

Recommended Posts

Hi Avenger86

Thank you reaching our here.

We have two PFCs in that model, one for high workload and the other for low.

I am guessing the PFC work with low workload is having some problems, maybe off setting.

Could you let me know the S/N number in the back of your power supply, and contact our Customer Service for a possible replacement.

and let us study the issue with your power supply.

Thanks.

Customer Service: 

USA/Canada/South America:
support@thermaltakeusa.zendesk.com 

Europe
support@thermaltake.de 

Australia/ New Zealand
rma@thermaltake.com.au 

Share this post


Link to post
Share on other sites
2 hours ago, Joshua Chang said:

Hi Avenger86

Thank you reaching our here.

We have two PFCs in that model, one for high workload and the other for low.

I am guessing the PFC work with low workload is having some problems, maybe off setting.

Could you let me know the S/N number in the back of your power supply, and contact our Customer Service for a possible replacement.

and let us study the issue with your power supply.

Thanks.

Customer Service: 

USA/Canada/South America:
support@thermaltakeusa.zendesk.com 

Europe
support@thermaltake.de 

Australia/ New Zealand
rma@thermaltake.com.au 

Hello, dear friend!  Serial number is PSTPI1050F2FDPE1AR000238 I sent it to support@thermaltake.de.

Tnx for answer!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...