Jump to content

TOUGHRAM software 1.0.6 does not properly recognize TOUGHRAM RGB


Recommended Posts

As the topic says - I recently purchased a 32 gb pair of 3.600 clocked TOUGHRAM RGB sticks, inserted them into my motherboard, loaded the XMP profile and ...

... first dissapointment - the system does not even boot at this setting.


Second issue is that the software does not properly recognize the sticks - while there is a temperature mentioned at least, I cannot get the RGB stuff working. The attached screenshot shows what I see - the preview frame remains empty no matter what I try and there is a row with letters (from A to H) that interferes with the RGB sliders. Am I the only one with such issues? I tried NeonMaker as an alternative - but that tool does not even detect any supported hardware.


I´m using a rather new platform (B550 chipset, 5800X CPU). Maybe Thermaltake needs to awake and release a newer version of the tool? While surprisingly enough the platform is recommended for my RAM.


Any help is appreciated.


My setup is as following:


msi MEG B550 Unify-X, AMD Ryzen 7 5800X, Thermaltake ToughRAM RGB, Aorus GeForce RTX 3080 Master, Samsung 980 Pro, WD_Black, Enermax MaxTytan 1050, NZXT H710i



Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

For several months I was unable to get a ToughRam 32GB kit to work with Thermaltakes TOUGHRAM RGB software ANY version before version 1.0.7 which now works reliably for me

All traces of the previous software should be uninstalled including the 'hidden' TT folder Located in:


Other RGB software installations may conflict also and should be removed before testing


Link to comment
Share on other sites

I did a fresh install of Windows meanwhile and used v1.0.7 , but no luck, the behaviour is exactly the same. Maybe the software fails due to my motherboard (only 2 instead of the usual 4 DIMM slots), but then again, why is it mentioned as validated?!

Fun fact - my e-mail inquiry is now 2 months ago ... and I never heard anything from Tt. To sum up things - software? Broken. Support? Not existing. At least msi released a newer BIOS meanwhile, allowing me to run the memory at 3.600 MHz.

Link to comment
Share on other sites

  • 1 month later...


ich habe keine #### mehr Englisch zu schreiben.

Die TOUGHRAM 1.0.7 funktioniert nicht richtig. Ich kann immer noch nicht alle LED´s ansteuern. Ich habe 4x8 GB R009D408GX2-4000C19A.

Wenn ich alle 4 Bänke besetze lässt sich das Letzte Modul nicht ansteuern. Besetze ich nur 2 Module, kann ich das zweite nicht ansteuern. Besetze ich nur eine Modul kann ich das nicht ansteuern.


Alle Ram Module werden richtig erkannt. Nur bei der Beleuchtung nicht.

Mein Rechner:

Asus ROG Strix X570-E Gaming, AMD Ryzen 7 5800X, Ram Thermaltake 4x8 GB R009D408GX2-4000C19A, 9x Thermaltake Riing Trio, AIO Thermaltake Floe Riing RGB 360 TT Premium Edition.

Die TT RGB Plus Software 1.4.2 arbeite ganz gut. Darf nur nicht auf Ramsync gehen. Dann stürzt die Software ab.

Bitte behebt den Fehler. Das kann doch nicht so schwer sein.



Link to comment
Share on other sites

  • 2 weeks later...

Some interresting findings.

The software suddenly starts to work when you shut down the PC after the installation. NeonMaker, however, still not works (it starts up, shouts because of a lacking controller and after a while it terminates). RGB PLUS 2 has been released recently and now looks more mature than before; it also claims a controller would be missing but when I klick on Lighting, the software works at least ...

... but where is smoke, there has to be fire as well. Literally in my case - both softwares cause the idle temperature of my CPU to increase by appr. 20 (!) degrees celsius. The temperature lowers immediately when shutting down the software ... but then the lighting stops to work abnd the default color flow is being presented instead.

Very, very strange. A basically good piece of hardware accompanied by a ridiculous bad software package.



Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

I have this same issue. It has/had something to do with seating the ram correctly, after I  removed two pieces and swapped them (for aesthetics nothing more as one had a lagging RBG). Doing so seems to have confused the motherboard as to what ram stick is in what slot?!? 

So, initially I installed my ram sticks correctly, staggered and was able to set the color as static red.  And then I was playing around and let it do the wave thing. I noted that one of the stick’s RGB was a little laggy. So I shut the machine down swapped the two pieces, to put the leggy one at the end so I wouldn’t see it as much.

So I shut the machine down swapped the two pieces, to put the leggy one at the end so I wouldn’t see it as much.

But I swapped two pieces of RAM side-by-side. REMEMBER if you are installing four sticks of 8 GB of RAM then you must STAGGER  their install (channels) of the pairs – you cannot install them side-by-side. so there I was breaking the Cardinal roll, first of all. I rebooted the machine, but saw that I hadn’t properly seated one of the pieces of ramp. So now, my computer only sees one pair - and because the others aren’t seated it’s now *incorrectly* installed (if it were a pair only it would have to be side by side 🤦🏼‍♂️)  


all of this to say that now my computer has two pairs of ram that it seems to maybe not know which slot there really in and if they are appropriately installed (I RE-checked after I corrected, see below), I don’t know if this even possible, for the MB to get confused about stick addresses - esp when it comes to the RGB part. Now, my RAM RGB behaves as if there are two distinct, pairs of RGB - neither of which I am controlling nor can I. The left has flows going on, the pair on the right does a wave. And I CANT turn them off even. ####  🙄

Also I have uninstalled all of my thermaltake software (RGB Plus, ToughRAM, and deleted the programs folder remnants too. 

next steps - going to use my core ASUS MB app Amoury Crate and see if I can control from there (and or if that was a conflict in the first place. You can use Armory Crate to sync your MB icon, MB addressable RGB, etc. I’ll post how I make out. If that doesn’t work I’m going to also - take the RAM out, go DOWN to 16 GB, properly installed 🤓, reboot, try RAM RGB then… etc. something to kick the addressing out of them, if that makes sense. 


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...