Jump to content

Riing 12 LED RGB Radiator Fan TT Premium Edition - Software not that great


Recommended Posts

I have a huge problem with the Riing RGB Software V 2.0.2

Firstly, while on the download page it says V 2.0.2, in the downloaded zip file it's 2.0.0?

During installation Microsoft Visual C++ 2015 Redistributable (x86) - 14.0.23026 want's that i change the setup (either repair or deinstal, i choose repair)

The bigger problem however occurs after installation. AVG shows a "Generic virus" alert for the Thermaltake RGB Fan Controller.exe

 

Despite putting the exe on the exceptions list, i cannot open the software. Nothing happens by double-clicking the start bar icon or the desktop icon. Neither does right-clicking work on the start bar icon.

 

At each reboot Windows asks me if i want the app from an unknown publisher to make changes on my device. And it shows the Thermaltake RGB Fan Controller.exe. Same note comes up when i double-click the desktop icon.

 

The deinstallation of V 2.0.2 was a nightmare. Not only it didnt remove everything of the software, i had to go into secure mode to be able to delete the rest... <_<

 

 

 

On V 1.0.2 i could, after applying the fix from ThermalHenry, atleast get it to work and change the colors and speed, but it didnt show the RPM (was on 0 all the time).

 

I have a windows 10 Pro x64

 

Why is there no "breath" option for the LEDs? That effect would be a massive improvement. I mean, we already can dim the LEDs, so thats obviously not a technical impossibility. :P

Link to post
Share on other sites
  • Replies 58
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I just received & installed nine new Riing 12 Premium radiator fans. The controllers are significantly smaller than the older non-premium models. Cable connectors are also smaller so no way to try

I just installed 9x new Riing 12 Premium fans in my case and the experience is lacklustre for a ‘premium’ version. OP nails it. The main issue for me is that the variable RPM doesn’t seem to ki

The new fans are very quiet and look really nice. I have 6 of these on the visible side of a node 804 case.   Being able to tweak the lighting on each of them is a lot of fun but I am having continuo

Posted Images

After forgetting to turn my fans back to pwm before gaming my water cooling loop exploded. temp got to hot and blew a fitting.. This would have never happened if the software was working,.. Also the website says the software release is v2.0.2. and the program is saying v2.0.1 ? And the installer says 2.0.0... So what version is it !!

 

Example: Right now My fans are at 1400rpm because the program thinks my pc is at 63c. When it is 33c. If you click the info button in the bottom left the monitor show correct info. the program is just not using it properly .

Link to post
Share on other sites

I have a huge problem with the Riing RGB Software V 2.0.2

Firstly, while on the download page it says V 2.0.2, in the downloaded zip file it's 2.0.0?

During installation Microsoft Visual C++ 2015 Redistributable (x86) - 14.0.23026 want's that i change the setup (either repair or deinstal, i choose repair)

The bigger problem however occurs after installation. AVG shows a "Generic virus" alert for the Thermaltake RGB Fan Controller.exe

 

Despite putting the exe on the exceptions list, i cannot open the software. Nothing happens by double-clicking the start bar icon or the desktop icon. Neither does right-clicking work on the start bar icon.

 

At each reboot Windows asks me if i want the app from an unknown publisher to make changes on my device. And it shows the Thermaltake RGB Fan Controller.exe. Same note comes up when i double-click the desktop icon.

 

The deinstallation of V 2.0.2 was a nightmare. Not only it didnt remove everything of the software, i had to go into secure mode to be able to delete the rest... <_<

 

 

 

On V 1.0.2 i could, after applying the fix from ThermalHenry, atleast get it to work and change the colors and speed, but it didnt show the RPM (was on 0 all the time).

 

I have a windows 10 Pro x64

 

Why is there no "breath" option for the LEDs? That effect would be a massive improvement. I mean, we already can dim the LEDs, so thats obviously not a technical impossibility. :P

Does you're update say 2.0.1 or 2.0.2 in the program ?

And Yes more led options !

Link to post
Share on other sites

I havent payed attention to what version number the intallation or program said, the instal exe was 2.0.0. It's #### (c'mon, i just typed "b.l.o.o.d.y", now that's an oversensitive censor filter imo) buggy, that's for sure.

 

I wonder how Tts reaction to the NZXT Aer HUE+ RGB fans is? Tt should better fix their software, add more LED effects and expand the "Premium" line to the RGB Fittings to compete with NZXT, because their HUE+ software is way more superior to what Tt has and the Aer fans RGB looks way better.

 

I would have switched to NZXT's fans in an instant if their LED ring wouldn't be just on one side of the fan housing. That's why i still have my Riing fans, because it's LED ring is in the middel of the fan housing and can be seen from both sides. Although it'd be WAY better if the clear ring would be satin instead of clear. When set on white, it diffuses the LEDs light badly and you can clearly see red, green and blue shining at the same time and casting differently colored shadows xD.

I thought about roughen the clear rings myself, but i just bought the fans and don't want to void any warranty if i break something while getting to the clear ring. I've read that when disassembeling the Riing fans, its almost always guaranteed that you break atleast one of the 8 clips that hold the frames together. : /

Link to post
Share on other sites
  • 4 weeks later...

Just recently bought a 3 pack of these fans to go with my core p3 that i just got. from the get go something was wrong and they wouldnt spin up, after a bit of trouble shoot i found out that i was using the wrong molax connector from my PSU. (evga has proprietary power cables for their modual PSU's apparently.) Switched cables and now they spin up and light up, down loaded the software and the mobile and the software doesnt see my fans. I'm just left with three blank boxes in the window. Got the app and connect and now it says APP is connect. This is a bit of progress, but i can still not program my fans at all. And theyre stuck being the default red at the moment. Any advice on a fix? 

Link to post
Share on other sites

Just recently bought a 3 pack of these fans to go with my core p3 that i just got. from the get go something was wrong and they wouldnt spin up, after a bit of trouble shoot i found out that i was using the wrong molax connector from my PSU. (evga has proprietary power cables for their modual PSU's apparently.) Switched cables and now they spin up and light up, down loaded the software and the mobile and the software doesnt see my fans. I'm just left with three blank boxes in the window. Got the app and connect and now it says APP is connect. This is a bit of progress, but i can still not program my fans at all. And theyre stuck being the default red at the moment. Any advice on a fix? 

Update:

 

Thermaltake got back to me and pointed me toward a doanload (1.02) and got that working so far, but now my rpms read 0 and i cant change the LED color or speed. =/

Link to post
Share on other sites

The v2.1.0 update fixes PWM issues with temp !

 

Finally happy with the state of the software. everything works .

I too am happier with the software :) It appears that the 'Temp' now points to the CPU package and updates the PWM function correctly. I'd love to be able to make my own performance curve or have a toggle for some of the controllers to be reactive to the GPU temp (I have 3 sets) in future updates.

It also does appear that the mobile app has lighting functions that the software does not (like the tri ring RBG rainbow button), so you can only toggle the lighting modes on the app? (Maybe that's just me)

 

Edit: English

Link to post
Share on other sites

There's an interesting bug in the latest version. If you're using any Corsair hardware with their CUE software, launching TT software makes all your Corsair hardware disappear from CUE. Thermaltake - how on Earth did you manage to screw up this badly? Please take a look at how CUE or CAM form NZXT software works. Right now I need to downgrade your software because it makes my other hardware unusable.

 

EDIT: anybody has a link to previous versions?

Link to post
Share on other sites
  • 1 month later...

hello. tried all the aforementioned fixes, doesnt work still. tried different versions of the software too, nothing. no rpm, cant control the speed etc. can only see the temps but idk if thats accurate. if i click the info button on the 1.0.1 software it takes me to a text document with these:

 

HWi32_GetVoltage:Core #0 VID = 1.11133

HWi32_GetClock:Core #0 Clock = 3300

 

question: does that mean the controller is actually communicating properly but its the software thats screwy? also i cant seem to find the version 2.1 etc of the software. if you click the download button on the site it downloads the 1.0.2 version and that doesnt work

Link to post
Share on other sites

I have a bunch of Basic version of Premium edition fans (120). Before I go ahead and install them, does the new software work or not? I'm not going to go through install all the fans just to find out the software is completely useless.

 

How I have my radiators setup it's hard to remove some of my fans due to all the tight space.

 

Whats the difference between these and the new Plus version other then what seems to be PWM and new controller box?

Link to post
Share on other sites

That's where I downloaded my 2.1 version from. What browser are you using?

chrome. is that the problem? ill try another

 

 

I have a bunch of Basic version of Premium edition fans (120). Before I go ahead and install them, does the new software work or not? I'm not going to go through install all the fans just to find out the software is completely useless.

 

How I have my radiators setup it's hard to remove some of my fans due to all the tight space.

 

Whats the difference between these and the new Plus version other then what seems to be PWM and new controller box?

 

 you wont know unless you connect em all. try it first with the fans out just the connections. if it works then take your rig apart

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...