Jump to content
Tack

Riing Plus Sound control low response

Recommended Posts

So I am getting very little response out of sound control when using my Logitech G933 even at max volume. I am getting great response out of onboard at max volume. Anyone else having this issue?

Share this post


Link to post
Share on other sites

Hi,

Sound control is based on System volume for max visibility.

For the lightning effects, it is based on the "bass" in the media being played as well.

Hope this will give some info to you how it is setup.

Let me know any feedback, I want it to be more sensitive, but not too much.

Share this post


Link to post
Share on other sites

Is there any way to have it be based on anything else, while still being consistent? I listen to a lot of metal with fast guitars and drums. Would be nice if it could be more reactive to guitars and higher pitched drums and cymbals.

Share this post


Link to post
Share on other sites

So I have found that in order to have the same amount of response out of my g933 headset as the on-board audio is to disable surround sound. Hope they add some sort of adjustment in the future.

Share this post


Link to post
Share on other sites

Hi All,

Working with our software team on some new features already, adjusting the sound control is on the list.

Appreciate the feedback, will have a new version coming out this weekend, but it will not be included that I know of just yet.

Either way it will be a free downloaded update version of the software, just give us some time to get it tested.

If I get any beta software, I will drop it on here for some feedbacks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×