Jump to content
Sign in to follow this  

Brand new iRGB 850W Platinum (DPS app suddenly not working)

Recommended Posts

I have a brand new iRGB 850w Platinum PSU

It was working previously, now i cant launch the app, it says "Could not setup a connection with power supply"

I have tried both usb 2.0 headers on motherboard (Brand new Z370-F) and i have even tried a normal mini-usb B to usb type A cable from my camera. 

Every time i connect it, i can hear windows reconsie it, then it gets "setup" successfully.

It comes up in device manager as a "HID-compliant vendor-defined device" under the human interface devices section/

What i have tried:

-Uninstalling and reinstalling

-Different usb cables

-Different usb 2.0 ports

-Trying a different version of the application


Share this post

Link to post
Share on other sites

SOLVED: You must close TT RGB PLUS software and any other software that may take control of your psu RGB's in the background. Then change the RGB settings in DPS G then close that and open the TT RGB PLUS software if you want to keep your fans actually changing colour not frozen in one state haha. 


Ill leave this thread open to help others 

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...