Jump to content
Jexx11

Control Team T-Force Delta RGB Ram with TT RGB Plus software?

Recommended Posts

Does anyone know how this works? On Team's website they claim this is possible and even on Thermaltake's site they say you can control this memory with TT RGB Plus software.

I can't find any options anywhere in the TT software that it can even see the Ram. I've Googled this issue and can't find any information on the topic at all.

My Asus Aura Sync can see the Ram just fine and control it, but the options are very limited so I wanted to try with TT RGB Plus.

Share this post


Link to post
Share on other sites
44 minutes ago, TT CPM said:

Hi, 

Do you have at least one Thermaltake product which is TT RGB PLUS enabled? Like a Riing fan or AIO?

 

Yes I have multiple Riing fans and also a Thermaltake AIO, which I control with TT RGB Plus.

Share this post


Link to post
Share on other sites

Before we move to the next step, just wanna check did you see T-Force memory in the RGB Sync page in TT RGB Plus like the attached photo.

You can click the little blue button on the top, then switch to RGB Sync page. 

Image 6.png

Share this post


Link to post
Share on other sites
12 minutes ago, TT CPM said:

Before we move to the next step, just wanna check did you see T-Force memory in the RGB Sync page in TT RGB Plus like the attached photo.

You can click the little blue button on the top, then switch to RGB Sync page. 

Image 6.png

No, when I click on the blue button and go to the RGB Sync Page it is blank, nothing is listed there.

Share this post


Link to post
Share on other sites
On 8/26/2020 at 9:56 AM, Jexx11 said:

No, when I click on the blue button and go to the RGB Sync Page it is blank, nothing is listed there.

Dear User

Could you take the TT RGB PLUS pictures for us? Product lighting control and RGB Sync page.

TT RGB PLUS supports the following types

T-FORCE XCALIBUR RGB DDR4 Memory Module
T-FORCE DELTA RGB DDR4 Memory Module
T-FORCE NIGHT HAWK RGB DDR4 Memory Module

https://ttrgbplus.thermaltake.com/Partner.html

 

Share this post


Link to post
Share on other sites
22 hours ago, Tony.P said:

Dear User

Could you take the TT RGB PLUS pictures for us? Product lighting control and RGB Sync page.

TT RGB PLUS supports the following types

T-FORCE XCALIBUR RGB DDR4 Memory Module
T-FORCE DELTA RGB DDR4 Memory Module
T-FORCE NIGHT HAWK RGB DDR4 Memory Module

https://ttrgbplus.thermaltake.com/Partner.html

 

Here are the pics you requested, as you can see nothing at all shows up under the RGB Sync Page "blue button" on top.

TT1.thumb.JPG.e9f3bcbb4cfe0d877010a16cdfe69199.JPG

 

TT2.thumb.JPG.53c20767fac77d1e32cb6881cfb50692.JPG

Share this post


Link to post
Share on other sites
On 8/25/2020 at 8:43 PM, TT CPM said:

Before we move to the next step, just wanna check did you see T-Force memory in the RGB Sync page in TT RGB Plus like the attached photo.

You can click the little blue button on the top, then switch to RGB Sync page. 

Image 6.png

I replied with pictures above

Share this post


Link to post
Share on other sites
3 minutes ago, TT CPM said:

May I know the model name of your T-Force memory?

Meantime, we already contacted Team group to check if they updated they hardware recently.

Team T-Force Delta RGB 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) Intel XMP 2.0 Desktop Memory Model TF3D416G3200HC16CDC01

 

This is the link from Neweggs site.

https://www.newegg.com/team-16gb-288-pin-ddr4-sdram/p/N82E16820331284?item=N82E16820331284

Share this post


Link to post
Share on other sites
3 hours ago, TT CPM said:

Hi,

Issue fixed, it will be included in next update early next month.

Thank you for the update!

 

Will I need to update firmware on my memory or will just updating the TT RGB Plus software resolve the issue?

Share this post


Link to post
Share on other sites
On 9/15/2020 at 8:57 PM, TT CPM said:

Hi,

No, just need to update TT RGB Plus, we will release it soon.  

There was an update today for TT RBG Plus to version 1.3.8.  I don't know if that is the version that is supposed to fix this issue, but it did not fix the issue I'm having.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...