Jump to content
Sign in to follow this  
Hyperkilljoy

THERON gaming mouse

Recommended Posts

Guest Tt Josh

Can you give us about the approximate time to solve the problem? I can not do my any work on computer for 4 days.  :(

 

I've check the webpages for the Theron line of mice. It seems that the firmware link has been taken down.

It's good to know you guys have recognized that the firmware is the source of all the issues we've been having. Still hopeful this will get resolved.

 

Waiting.

 

Hey guys, sorry for the delay!

 

Try this firmware and see how it goes!

 

Click HERE to install!

 

Also keep me updated too! ;)

Share this post


Link to post
Share on other sites

Thanks. Will check it out once I get off from work. I'll let you know what happens.

 

Edit: Not sure if this is the same firmware that you gave us last time, but sorry to say, no dice.

Problem still remains. The cursor moves only when I lift the mosue off and onto the desk.

 

I've messed around with the liftoff tool to see if anything happens.It doesn't.

 

Anyone else tried this? Waiting.

Edited by tinman072

Share this post


Link to post
Share on other sites
Guest Tt Josh

Thanks. Will check it out once I get off from work. I'll let you know what happens.

 

Edit: Not sure if this is the same firmware that you gave us last time, but sorry to say, no dice.

Problem still remains. The cursor moves only when I lift the mosue off and onto the desk.

 

I've messed around with the liftoff tool to see if anything happens.It doesn't.

 

Anyone else tried this? Waiting.

 

I totally agree tinman072. Problem still unsolved. But increased sensitivity a bit like of cursor when lift the mouse off on to the desk.

Let me send a feedback to them and let them know about this unresolved firmware! I'll let you guys know once I get the info! ;)

Share this post


Link to post
Share on other sites
Guest Tt Josh

They're currently working for it and solution will be coming out soon! I'll keep you guys updated!

 

Sorry for delaying! ;)

 

Josh

Share this post


Link to post
Share on other sites

I am happy to let everyone know that the firmware provided above is working perfectly.

Sensor now tracks without issues. All buttons are working as they should.

Sensitivity can be controlled on the fly using the buttons. Profile switching is perfect.

 

You guys really came through. Hats off to TtJosh and the entire TtEsports team. Thanks so much.

After this I might just pick up a Poseidon ZX to go with my Theron :)

 

 

Edit: Just finished a round of CS:GO deatchmatch. This things works like a charm. As if nothing ever happened!!! :)

Thanks everyone.

Share this post


Link to post
Share on other sites

Hi guys unfortunately I have the same problem. Today my Theron does not respond to movement (including uefi bios screen), but oddly enough the left and right click and side buttons, mouse leds and scroll works fine. Tried everything and finally I found this topic in Google. I downloaded latest firmware from Theron website (http://usa.ttesports.com/productPage.aspx?p=28&g=ftr) and uptaded but nothing happens. I am strongly guessing this is the firmware problem. I am very disappointed. Why it was without rhyme or reason? I got the mouse maybe 1 years ago or little more use nothing any problem. I tryed Tt eSPORTS THERON Update Tool V1.1 and [New 2015] V1.3 firmware but dosen't happens. Some friends have solved the problem but not me. What can i do? Who can help me? Thank you.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi guys unfortunately I have the same problem. Today my Theron does not respond to movement (including uefi bios screen), but oddly enough the left and right click and side buttons, mouse leds and scroll works fine. Tried everything and finally I found this topic in Google. I downloaded latest firmware from Theron website (http://usa.ttesports.com/productPage.aspx?p=28&g=ftr) and uptaded but nothing happens. I am strongly guessing this is the firmware problem. I am very disappointed. Why it was without rhyme or reason? I got the mouse maybe 1 years ago or little more use nothing any problem. I tryed Tt eSPORTS THERON Update Tool V1.1 and [New 2015] V1.3 firmware but dosen't happens. Some friends have solved the problem but not me. What can i do? Who can help me? Thank you.

Hey HWS,

 

Try to uninstall the software and install the software below:

 

 TT ESPORTS THERON FIRMWARE V2.0

 

If it's still unresolved, try it on another computer or laptop (if you have), and please tell us which country you're from.

 

Keep me updated! ;)

Share this post


Link to post
Share on other sites

Hey HWS,

 

Try to uninstall the software and install the software below:

 

 TT ESPORTS THERON FIRMWARE V2.0

 

If it's still unresolved, try it on another computer or laptop (if you have), and please tell us which country you're from.

 

Keep me updated! ;)

 

Hi Josh,

 

Thank you for your quick answer.  :) I am writing to you from Turkey. My Theron warranty continues. I bought my theron, Feb 24th 2014.

 

I installed the software, you gave the link above. But never had a change. After the firmware update, do I need to restart or do I need to do after installing the firmware update software?

 

The installation screen was performed as in the links below.

 

http://abload.de/img/screenshot_1ivumv.jpg

http://abload.de/img/screenshot_2lputd.jpg

 

The pictures of the my theron mouse you can see below.

 

http://abload.de/img/20150427_121142iiuro.jpg

http://abload.de/img/20150427_1211276nukv.jpg

 

Thank you for your help.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi Josh,

 

Thank you for your quick answer.  :) I am writing to you from Turkey. My Theron warranty continues. I bought my theron, Feb 24th 2014.

 

I installed the software, you gave the link above. But never had a change. After the firmware update, do I need to restart or do I need to do after installing the firmware update software?

 

The installation screen was performed as in the links below.

 

http://abload.de/img/screenshot_1ivumv.jpg

http://abload.de/img/screenshot_2lputd.jpg

 

The pictures of the my theron mouse you can see below.

 

http://abload.de/img/20150427_121142iiuro.jpg

http://abload.de/img/20150427_1211276nukv.jpg

 

Thank you for your help.

Hey HWS, once the installation has completed, close the update window and try to restart your computer. 

 

Keep us updated! ;)

Share this post


Link to post
Share on other sites

Hey HWS, once the installation has completed, close the update window and try to restart your computer. 

 

Keep us updated! ;)

 

I did the firmware update. Then I installed the pc software of Theron. Then I restart the PC. But unfortunately nothing happened. Mouse does not move. I want to install the firmware again, but it says " THERON not need update firmware !! ". I've added below the screen image that.

 

http://abload.de/img/screenshot_3hduhd.jpg

 

Solves the problem to install the factory firmware version?

Share this post


Link to post
Share on other sites
Guest Tt Josh

I did the firmware update. Then I installed the pc software of Theron. Then I restart the PC. But unfortunately nothing happened. Mouse does not move. I want to install the firmware again, but it says " THERON not need update firmware !! ". I've added below the screen image that.

 

http://abload.de/img/screenshot_3hduhd.jpg

 

Solves the problem to install the factory firmware version?

Hey HWS, try install this:

 

Click HERE to install.

Share this post


Link to post
Share on other sites

Hey HWS, try install this:

 

Click HERE to install.

 

Hi Josh,

 

Thanks for the effort and your response regarding the issue.

 

I'm sorry to report that unfortunately did not work firmware recently submitted. Buttons, leds and scroll works fine but my mouse cursor still does not moveAfter installing the new firmware, I restart my pc and tried to set default in the AP V1.3.1 by clicking the default icon but did not change anything. By the way new AP V1.3.1 it still showed VERSION 1.00 in the top right corner. Is that a problem or normal?

 

http://abload.de/img/screenshot_13luz7.jpg

http://abload.de/img/screenshot_2d8ugz.jpg

http://abload.de/img/screenshot_3vruz9.jpg

http://abload.de/img/screenshot_42bu3q.jpg

 

A firmware is that it can be inconsistent? Working in some people but it does not work well in some people. Really strange.

 

I really need a firmware update fix or a way to reset (revert) to the default factory firmware to fix the issue I am having.

 

Thank you.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi Josh,

 

Thanks for the effort and your response regarding the issue.

 

I'm sorry to report that unfortunately did not work firmware recently submitted. Buttons, leds and scroll works fine but my mouse cursor still does not moveAfter installing the new firmware, I restart my pc and tried to set default in the AP V1.3.1 by clicking the default icon but did not change anything. By the way new AP V1.3.1 it still showed VERSION 1.00 in the top right corner. Is that a problem or normal?

 

http://abload.de/img/screenshot_13luz7.jpg

http://abload.de/img/screenshot_2d8ugz.jpg

http://abload.de/img/screenshot_3vruz9.jpg

http://abload.de/img/screenshot_42bu3q.jpg

 

A firmware is that it can be inconsistent? Working in some people but it does not work well in some people. Really strange.

 

I really need a firmware update fix or a way to reset (revert) to the default factory firmware to fix the issue I am having.

 

Thank you.

I'll escalate the issue to our Product Management team and will get back to you once I got the solution ;)

Share this post


Link to post
Share on other sites

I'll escalate the issue to our Product Management team and will get back to you once I got the solution ;)

 

Thanks Josh. At least it's good to know you guys are working on it. And thank you for your patience with us.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Thanks Josh. At least it's good to know you guys are working on it. And thank you for your patience with us.

No worries! We'll fire you a reply once we get the solution! ;)

Share this post


Link to post
Share on other sites

No worries! We'll fire you a reply once we get the solution! ;)

 

Hi Josh, can you give me about the approximate time to solve the problem? I can not do any work on theron for 1 week. I have to use a different mouse.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi Josh, can you give me about the approximate time to solve the problem? I can not do any work on theron for 1 week. I have to use a different mouse.

I'll check with the team and get back to you soon! In the meantime, kindly contact our customer support at cs1@thermaltake.com, they might have a replacement for you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...