Jump to content

Riing Plus 12 LED RGB Fans not detected


Recommended Posts

I bought  6 TT Riing Plus 12 LED RGB fans and  installed them in my new system and have 3 each on each digital controller. They are spinning and lighting up, but in the software(V1.0.2 and 2.1.2) they are not detected. I can't select a Hub number in the upper left corner. The fans are shown as 0 rpm and I cant change the color either 


The internal USB 2.0 header works fine with everything else i connect to it. The motherboard I use is the Gigabyte Z170X gaming 5.


Does anyone have an idea why this is?


Any help would be greatly appreciated!






Link to comment
Share on other sites

I can help you here! Thank me later. There are a number of things that can fix this problem, but I'm going to ask you to do something strange. You should in screw the plastic hub housing from the controller and remove it entirely.


Once you have it out of the box unplug the micro USB side then plug it back in. Restart your pc. I actually have the naked hub mounted to the rear of my motherboard tray and have no issues.


I have a feeling you will be surprised this works. There are a few reasons why but the most important is the USB connection isn't sitting well and not allowing the software to read the box. Also look for a white glue substance behind the USB connection, if there is a lot scrape some away.


Hopefully your comfortable doing this and I get it your product isn't working as intended but it will fix your problem , if it doesn't I know a few more things to try but do that first.


Also your title says riing plus and that software your using is for riiing premium. Plus fans are better than premium and just came out.

Link to comment
Share on other sites


              IT WORKS!!!      


As funny as it sounded , it worked perfectly . And best of all all I did was loosen out the screwsa  on the hub a lill bit , didnt even have to remove the cover.Its sad that a product costing so much has such QC issues, Im still waiting on the support ticket I had put in to see if they wud send me a replacement part which I wudnt have to tinker with lol 


But thank you aggain


and , thank you for the heads up on the title , i actually have the Riinng 12 RGB Premium edition ones.


Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Can anyone tell me where you got the Riing Plus 12 RGBs? I bought the Riing 12 TT Premium Edition on accident and was really looking for the Riing Plus. TTs look great but software is limited and I wanted to do more with the product.

The Plus fans don't work any better. Don't waste your money until TT bothers to make functional software.

Link to comment
Share on other sites

  • 3 weeks later...
  • 4 years later...

Somehow im finding your guys solutions strange, though possibly valid i dont know yet. However im having the same problem, long story short i did some thing bad to my motherboard and cpu. Ended up replaceing both, with a ryzen 3700x and gigabyte auroruas elite v2. However after going through te process of getting raid to work needed to install it on a single m.2 first, followed by loading the driver from amds website, to resetting up raid and installing windows. So sorry long enough already just my day but the point im making is after boot up, installed the software it all worked fine let me change colors, and do everything. Shut down now back up no connection to controller.............................will try removing software again, if not i will try it your guys way

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...