Jump to content

Riing Plus second controller not working


Hippomedon
 Share

Recommended Posts

I have a 5 fan Riing Plus setup with the 5 port non-sync controller. This controller connects to a USB header on the motherboard.

I want to add another Riing Plus fan, and this controller can be daisy chained according to Thermal Take, so I purchased another 5-port controller and another Riing Plus fan.

The controller came with a USB header/Micro usb cable, a molex power cable, and the "bridge" cable (this has a four-pin connector on one side, and a Micro USB on the other).

The directions are not clear, they only indicate that you can plug the bridge cable into the second controller. I tried plugging the four-pin side of the bridge cable into the first controller, and the micro-USB side of the bridge cable into the second controller. I connected molex power and my extra Riing Plus fan into the second controller. I powered on the system and the second controller was not recognized in the Thermal Take software (v1.2).

The extra fan did spin up in default RGB mode, I assume because it was getting power from the second controller. But, no second controller showed up in the TT software. Did I connect everything together? I shut down, disconnected and reconnected and it still didn't work.

 

Thanks!

 

Link to comment
Share on other sites

Hi,

Did you set the dip switch to like #2? both controllers cant be on #1 or it wont show up.

About the daisy chain stuff, you can use either of the 2 connections from the USB header Y cable and anything after that will use the link cable.

You can plug in #1 controller to the cable from the USB header on the motherboard and then link with the daisy chain cable for #2 as well.

Either or dont matter, all that does matter is the dip switch to assign the controller #1-16

Link to comment
Share on other sites

thank you. I followed these directions and the second controller appeared int the interface as controller 2. I was able to configure the extra fan by switching to controller 2 in the software. Everything was working as expected.

After a restart, however, I got a warning controller 2 error, and the controller 2 icon is now red in the interface. I can't change the fan's colors anymore, just the light pattern, and when I try to save a profile, the fans on the original controller change color, or shut off, at random.

Not sure sure what I should do! I tried unplugging everything, restarting, plugging back in, restarting, still  the same issue.

Link to comment
Share on other sites

Hi,

First off, when you get the alert message, make sure to click ok to close it.

Then, there is likely a port empty, which the software will alert you that nothing is detected.

Click that blue circle on that port in the software to turn it red (Disabled) if nothing is on that port and the software will stop alerting you about it.

As for the changes and saving, make sure each controller is on the right profile, they can all be different as well.

Check your connections too.

 

Link to comment
Share on other sites

thanks, it was actually a green circle to disable empty ports on the second controller, now the fan error is gone.

 I still have to restart the software everytime I change a fan color or profile for it to "take" but that seems like a separate issue, maybe I'll re-install and see if that helps.

Thanks for your help.

 

Link to comment
Share on other sites

  • 10 months later...

So I’m having somewhat the same problem, I can’t get a second fan controller to show up, I’m running 10 of the riing premium plus fans, but only 5 show up in the software obviously because the other controller isn’t showing up. I swapped the controller to a spare that I had and still won’t show up, I’ve also played with the dip switches and reinstalled the app. Kinda lost at this point 

Link to comment
Share on other sites

  • 1 year later...

I'm also having a similar issue. I have 6 of the riing quad fans and 2 x 5 port controllers (Fans 1-5 on controller 1 and fan 6 on controller 2). I was able to get both controllers to show up last night, but then after a shut down for a few hours and turning the pc pack on again. I now only see controller 2. 

I also had neon maker able to see all 6 fans last night and now it can only see the 1 fan I have on controller 2. 

 

 

Motherboard Gigabyte x570 gaming x

CPU: Ryzen 3900x

Ram 4 x 8 Kingston Fury X 3200Mhz

GPU: MSI Geforce RTX 2070 8GB

Keyboard: Corsair K95 Platinum XL

Mouse:  Logitech M600

 

Link to comment
Share on other sites

7 hours ago, James Pisanich said:

I'm also having a similar issue. I have 6 of the riing quad fans and 2 x 5 port controllers (Fans 1-5 on controller 1 and fan 6 on controller 2). I was able to get both controllers to show up last night, but then after a shut down for a few hours and turning the pc pack on again. I now only see controller 2. 

I also had neon maker able to see all 6 fans last night and now it can only see the 1 fan I have on controller 2. 

 

 

Motherboard Gigabyte x570 gaming x

CPU: Ryzen 3900x

Ram 4 x 8 Kingston Fury X 3200Mhz

GPU: MSI Geforce RTX 2070 8GB

Keyboard: Corsair K95 Platinum XL

Mouse:  Logitech M600

 

Hi, 

It seems a voltage issue, cuz riing quad features 54 LEDs on each fan, i would suggest that move 2 fans from controller 1 to controller 2, means one controller only plugs 3 riing quad fans, please let me know if it works.

Link to comment
Share on other sites

  • 4 weeks later...

So I'm having a problem where my first controller runs fine, but the second controller apparently is hated by my software and it refuses to boot when the 2nd one is plug in, even by itself. It will boot up when either no controller is hooked up or controller 1 is but will crash or not boot when controller 2 is involved. The fans connected still run but I can change the fan speed nor the color. I have tried the y cable, the daisy chain (which is actually when it started to refuse to boot). Reinstalling the program and even deleting the RGBRiingPlus file inside my appdata folder and nothing has worked.

PS: If I do I need to buy a new controller and if I do what should I get? (My motherboard does NOT HAVE A 5 VOLT HEADER)

Link to comment
Share on other sites

  • 11 months later...

Hello, i am having a similar issue, i have 6 riing trio fans, 3 in each 5 port controller, and when i start the tt RGB plus app, be it in the boot or manually, the second controller stops being recognized, but when i unplug and plug back the power from the second controller, it is recognized by the app, the problem seens to be in the app startup

Link to comment
Share on other sites

I recommend you improve your skills in software development. So, what exactly should you be looking for in an on development professional? In order to find the best ios app developers, it's important to understand app development terminology and best practices. In particular, you want to make sure you're working with someone who has the right skill set for the job. For example, there are two different ways to write Objective C applications, and one of those is the  there. You might want to talk to app software development professionals who are skilled in using both of the different programming interfaces, so you won't end up making the same mistakes they made.

Link to comment
Share on other sites

  • 1 month later...

I am having similar issues to these other guys. I have two controllers set up plugged into one of the USB motherboard connectors. I downsized from three as the third stopped being recognized. Now the second controller is not being seen. Since restart the TT RGB Plus software also does not see the Toughpower iRGB PSU either. I will have to admit I am super disappointed as I have liked Thermaltake gear for a long time and this is my first upgrade in 7 years an now you guys are selling gear that is not user friendly. I have 2 x Riing trio 20 and 3 x Riing 12 fans on the first controller and 3 x Riing Trio 14 and 1 x Floe AIO on the second. I am considering returning it all directly to Theremaltake as this should not have to be dealt with by Scorptec Computers who have done nothing wrong. The controllers do not work as they should. Also on my Riing Trio 20 fans 3 of the LEDS in the middle just go whatever colour they feel like and cannot be addressed. Poor form.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...