Jump to content



Recommended Posts

hi, I've got my mouse few days ago and the driver told me to update the firmware this morning, when i press the update now button, it did not update and the mouse's light turned off and disabled. I reconnect it and it show i hv connected a IRIS RGB bootloader. The driver still said i need to update the firmware but i pressed both the later and update now button,nothing happened and the mouse still not working . can someone help me plz

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
  • 3 months later...

Oh finally I found someone with the same problems. I thought i was the only one. Except I've got my mouse 4 months ago.

I've contacted the seller I got my mouse from, to which he told me to reach out to Thermaltake through facebook. I'm currently waiting for a reply, it's been about more than 12 hours since I've messaged them and still no reply.

Link to comment
Share on other sites

Ok guys, so I found a forum for the same problem but with the Neptune Elite keyboard instead, however in that case, a PM came by and dropped a link to a file to fix the update.
Here's the link: https://drive.google.com/open?id=1voGuwm1daSZvXEc6wa8_lfnrxovsjXeQ


Here's the full reply

"Good day, I’m Thermaltake PM, Stephen. I understand that there’s been an error during the FW update on your Iris MIKU Edition mouse.


Please update the mouse again via the FW updater file, link below. If any question, please let me know.




Thank you for your patient and understanding. We apologize for the inconvenience


Best Regards,


Stephen Chiang

Product Development 

TEL: +886-2-87975788 #2856

Mobile: +886-910-279-425

Email: stephen.chiang@ttesports.com



Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

Alright, im facing the same problem as you do.
I do own the mouse like few month ago (this year).

The link given are the firmware update for,

the size is around 400kb (100kb+, for the rar file)
After you extract them, you might wanna disable antivirus. Because it would totally blocked the update and ended being unresponsive (Not Responding).
So, is just click and launch. 
took me 2 hours to resolve this haha. While watching Kimetsu no Yaiba .

Biggest ooF Ever.

Link to comment
Share on other sites

  • 11 months later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...