Jump to content

View 37 ARGB Fan problem


Recommended Posts

17 hours ago, Tech Geek said:

I'm not sure if the motherboard or software is actually doing any auto-detection.  I just found a tutorial from ASUS explaining the ARGB configuration and how to set it up this is the link:


Here is the excerpt from it that addresses how to set it up:


Aura Sync treats our light strips’ addressable LEDs as one entity, for the most part. They’re all represented under the “Add Strip” label in the Aura UI. if you drill down in the software, however, you’ll find the headers identified individually. Each header supports up to 120 addressable diodes, and Aura needs to know how many LEDs are on each one to work properly. Configuring our build’s addressable strips in Aura Sync was as simple as navigating to the Addressable Headers section, punching the number of LEDs into the appropriate text box, and then clicking Save.

It says nothing about it detecting it, it clearly says you have to tell it.  So in our case why do we need to have the controller cable unplugged during boot for the software to allow us to adjust (and have it save) the Number of LEDs?

Yup!  But in our case (no pun intended) the number of LEDs in Aura under the header that the TT controller is plugged into is LOCKED at "1" (which is probably a closed circuit) or at least very low resistance.  If Aura would let us adjust the number of LEDs in this case  then this problem could likely be resolved. 

Link to comment
Share on other sites

2 hours ago, jujunet said:


I used to looking for some system file or reg key with the number led information. My idea were to load a modified file or key automatically with a .bat file at windows loading. But I found nothing about that, no .ini file or something else. Look to regedit and nothing found.

I will go to my solder iron and build my cable and say goodbye to the TT controller. 😄

Switch on RGB cable is a good idea too, but very tedious, you have to manually change led number.

maybe a resistor that could fake the resistance needed to convince Aura that there are 27 (or so) LEDs

I'll investigate...

Link to comment
Share on other sites

9 hours ago, GregAMD said:

Yup!  But in our case (no pun intended) the number of LEDs in Aura under the header that the TT controller is plugged into is LOCKED at "1" (which is probably a closed circuit) or at least very low resistance.  If Aura would let us adjust the number of LEDs in this case  then this problem could likely be resolved. 

You actually have it backwards.  If it's looking for a load (load sensing) on the 5V line, it will expect to see a low resistance.  If it sees a high resistance or open then it would assume no load (0 or low number of LEDs).  I did some inspection of the PCB and measuring.  The 5V coming in from the ARGB connector doesn't go anywhere.  The 5V out to the fan is being sourced from the SATA connector (verified with a multimeter).

So if you want to use a resistor believing the motherboard is load sensing (which I'm not convinced is happening, but not certain), then you would want a resistor placed across the 5V (on the ARGB connector) to ground (any ground as they are all connected), not in series with the 5V line.  This will place a load (presently it's open due to it not being used) on the 5V line coming from the motherboard.  I would start with a higher resistance (1K) and drop it slowly until it reads something other than 1 in Number of LEDs.  This is all with the presumption that there is load sensing going on here and Aura monitors it real time and not just at boot.

Link to comment
Share on other sites

As to the above, the easiest place to put the resistor is push it in the back of the connector that plugs into the ARGB connector on the motherboard.  You could slide the leads of the resistor down in alongside the sockets in the connector from the backside.


CAVEAT:  Any of this type of testing presents a risk as I and everyone else here have no intimate knowledge of the circuitry involved.  I haven't done any reverse engineering of the motherboard, and I've only done very basic research on the controller (to ascertain that the 5V from the motherboard is connected to nothing on the controller) for my own interest.  So if you use this information or my suggestions presented here, DO SO AT YOUR OWN RISK.


Link to comment
Share on other sites

Again as I stated awhile back, if load sensing were occurring, why does leaving the cable unplugged have any affect?  The 5V line is presently open when connected the controller, which is essentially what you have when the cable is unplugged.

So while I'll agree there must be something being done on the motherboard end to cause Armoury Crate to allow changes to be made to Number of LEDS field when the cable is unplugged, I still am not certain what is being done.  


Added my Police Cruiser effect I created in Aura Creator.

Link to comment
Share on other sites

okay, so i gave it another look, and yeah, i may have just not rebooted enough times.

what i've done now is taken the thermaltake "controller, and removed EVERYTHING from it except the connectors. i took every resistor, capacitor and the 2 IC's off the board. 

i cut off the sata power connection  and rewired the 12v and gnd to a fan plug,

i then soldered a jumper from the 5v pin of the mobo argb in header to the 5v pin on "fan 1" and the same with digital in to the dig in on "fan 1"

now the fans get fan power, and the leds get argb 5v, dig in goes to dig in on fan 1, and daisy chains from there.


sure tt is never gonna honor the warranty on it, but did anyone still believe that they ever would?

also, i did verify that the "I" on the board is not a tach line, its actually ground for the 12v system.

so there is no tach, the fans just spin at whatever speed the 12v sends them to.

as in + and - instead of 12v and gnd.

dunno why they did that, but yeah.

also, in case you were wondering, both grounds are tied together on the board within the fans, so i would still recommend replacing those soon anyways.



this isnt a perfect soloution, but it works wonderfully.

remove everything from board
jumper aRGB: 5v to fan 1: 5v
jumper aRGB: Di to fan 1: Di
connect 12v and - on "com 1" to a chassis fan header, or leave it if you feel like wasting a sata connection.
restart your computer.



p.s.: i know i hacked the board mod up, i was getting a little frustrated the other night.



Link to comment
Share on other sites

I have a solution to this problem too... Though mine is a little less drastic and mine is likely warranty friendly. 😀

I have now confirmed that the problem exists in how the MB (bios) senses the DATA line on the header and the TT Controller.  They just don't get along.  I have not determined if a resistor would solve this.. But simple SPST switch will.

Simply splice a switch into the data line (middle of the three wires) that connects the MD to the TT controller

During a cold boot (PSU switch OFF) leave the switch open...

Launch Aura and now the number of LEDs is editable.  Set the number of LEDs to 27 (9 per fan) and then

Close the switch and all of the LEDs play. 

I will post a photo later... though this is dead simple.  A bit of a pain... but dead simple.  And the board remains unchanged and still does all of the stock light shows if that is desired.

Link to comment
Share on other sites

18 minutes ago, todd200 said:

Awesome work! Is it possible to get some more pics of the mods so those of us less electrically astute could do it with the least likelihood of frying something?

literally remove everything else from the board. I'm sure there are more elegant solutions, but I am honestly over it. 

I got more than a little frustrated with the while thing, because argb circuitry is honestly really simple, and i think tt overcomplicated their circuitry. 

the ic's are great if you dont have a header on your board, but they interfere with the data line if you're trying to do anything with the mobo. 

you can honestly cut the resistors and ic's off with pliers if you want, the only signals you are worried about are on the edge of the board and only go from one connector to the next in line. 



Link to comment
Share on other sites

Hi cplpunishr,

Did you figured out why it wouldn't work when you wired directly the RGB header to fan ? It seems that your mod is same thing with the jumpers. Other wirings from fan 1 to 2 and 3 are going through the pcb tracks. It may be similar to my cable plan. Bad news for tacho, I will cable directly with sata 12v.

Link to comment
Share on other sites

I was thinking like jujunet that the number of leds for the addressable headers must be stored somewhere.  No luck searching the registry but after expanding my search I found them!  In the Lighting Service folder open the file LastProfile.xml and scroll to the bottom.  Ta Da!  That's the good news.  I uninstalled Aura Sync and replaced it with the latest version of Armory Crate.  All my devices are recognized and you can actually update the number of leds.  Unfortunately it doesn't stick, completely.  You still have to disconnect/reconnect the header to make it work but it persists if you only restart.  If you shut down completely it breaks again.  Also, check out the LightingService.log file and you'll see that the values seem to be coming from the xml file.  It also seems to be calculating and/or writing the number here:  AACAddressableStrip::DoMakeLeds.  I'm getting close...


Link to comment
Share on other sites

Great news Bryan,

I tried something but, no luck. I tried to take own of the lastprofile.xml file (Total Control), and modify the line :

 <addressable_strip_led_count key="1">1</addressable_strip_led_count> to  <addressable_strip_led_count key="1">27</addressable_strip_led_count>

It seems that armoury crate modify this line when you enter manually the led number. But when you look somewhere else in the software, and you return to the led number page, it goes back to 1 !

I tried to lock the file in read only, but the software continue to display 1 even when 27 is always in the file...

Other thing : I started to try during an half hour and I notice that my RGB header was unplugged, I forgot to replug it last time I took a look inside my case. And I had one led illuminated on the first fan ! The issue is same whatever the RGB header is plugged or not ! But of course no sync when unplug.


EDIT : It seems like the line isn't modified anymore now that the RGB header is plugged. 🙄

Link to comment
Share on other sites

On 2/22/2020 at 5:53 PM, jujunet said:

Hi cplpunishr,

Did you figured out why it wouldn't work when you wired directly the RGB header to fan ? It seems that your mod is same thing with the jumpers. Other wirings from fan 1 to 2 and 3 are going through the pcb tracks. It may be similar to my cable plan. Bad news for tacho, I will cable directly with sata 12v.

yeah, i just skipped a reboot.

you need to plug everything in, then reboot.


but yeah, im just using the board for it's connectors



Link to comment
Share on other sites


I copied the XML file, modified the copy, deleted the original, and copied the modified file back to the LightingService folder.  That actually worked as long as I didn't power down completely (you still have to unplug the header, etc.).  Unfortunately, it's a constant battle with the service AACAddressableStrip::DoMakeLeds as to whose update sticks.  I pretty sure that's the code that ASUS needs to modify for a permanent solution.

Link to comment
Share on other sites

OK, I got tired of waiting on ASUS and them asking stupid questions rather than fixing their software.  I have a relatively simple modification to the board that will get this working.  After tracing out the circuit it's a simple matter of removing U1.  Actually you could lift/cut the legs/pins 5 and 6, but removing it maybe easier.  Once this is complete, the switch used to switch color/effect/mode no longer works, but I assume you don't want that functionality anyway.  Actually you could repurpose this switch as a system reset switch.  Just to be clear nothing else needs to be done.  I've attached a picture of what the board looks like just so you can see nothing else needs to be done.  No need to add wires, short anything, etc.


The software will default to 120 LEDs, so if you don't want a gap in the effect (while it's talking to LEDs from 28 - 120) make sure to set that number to 27.  Presumably if you have the right connector you could use the ARGB out connector (for the fourth fan) to run an ARGB strip.  Of course you'd have to add those LEDs to the total.


Link to comment
Share on other sites

Ta da!  I still have to button it up and remove the plastic but the lights all work with one exception.  I still have an issue with the lights on my 2nd GPU lagging behind everything else.  When I open Armory Crate and go to devices I only see 1 Radeon RX580, should I be seeing 2?  I'll post a pic of the finished product when I'm done.



Link to comment
Share on other sites

Very nice.  I see you went ASUS / TT.  Mines a bit of everything.  I've got an EVGA SuperNova 1000 G2, TT View 37 ARGB, ASUS Prime x570 Pro, AMD Ryzen 3700X, ASUS Strix RTX 2060 Super, 16GB G.Skill Trident Z RGB DDR4 3200, Samsung 970 EVO Plus 512GB, WD Blue 4TB HD, Fractal Design Celsius S36.  I kept the GPU and PSU from my last build.  I was torn on this build, I've always built Intel for myself, I've built AMD for my kids, but never for myself.  I also wanted an ASUS Strix MB, but it was just too expensive for what I was going to use it for.

Overall I'm happy with my system.  I was glad to get this RGB thing working.  If I could get my system to POST with the advertised speed of my RAM I'd be even happier, but I think it's more of an issue with the motherboard starting the DRAM Voltage at 1.2V.  Of course ASUS support won't even discuss the issue if the RAM isn't on the QVL.  So I'm running it at 2933 (even divider keeps everything at a 1:1:1) which isn't too much of a loss of performance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...