Jump to content
Sign in to follow this  
mindPreBlown

TT RGB Plus software not working after sleep TEMPORARY FIX

Recommended Posts

So i spend $100+ on the Riing Plus RGB premium edition just to find out the software is a pain to use, no fan curve, no GPU temp and the modes are not drop down menus so you have to cycle through everything to find your favourite ones.

But those are luxury options, WHICH I EXPECTED ON A PREMIUM PRODUCT, but it doesn't bother me that much. But every time my PC wake up from sleep, the RGB fans basically reset to their default lighting mode and becomes unresponsive to the software changes. WHAT.

To make the software and RGB fans in sync again, you need to close to software and restart it. This step may sounds simple and it is, but it's just shouldn't be there for a premium product and it annoys the crap out of me.

I searched the forum saw these posts:

basically the admin says: yeah it's not our problem it's the hardware's limitation. LOL and one of the guy even shows the admin a way possibly and easily to implement a 'reboot' into the software and here i am 1 years later on V1.2.2 nothing changed. What A Joke.

Anyway, if anyone else want to solve this problem, i solved it by taking the long route of using AHK and windows 10's task scheduler:

1. download AHK and create a AHK script with following in it:

Sleep, 3000
Process, Close, TT RGB Plus.exe
Sleep, 2000
Run C:\Program Files (x86)\Tt\TT RGB Plus\TT RGB Plus.exe
Sleep, 15000
Process, Close, TT RGB Plus.exe

2. open Task Scheduler -> create basic task -> change trigger to "when i log on" -> start a program -> navigate to your AHK script -> Finish.

3. now find your task in the among the list, double click it, go to triggers, delete the existing ones, click new choose at log on for any user, uncheck all box except for first and last, change delay task to 5 seconds, click ok.

4. click new again, this time choose on workstation unlock for any user, and same check box and timer as previous one, click ok.

5. finally in the settings, the last drop down menu should be stop the existing instance.

Now to software should automatically reboot after wake/sign in. Those are just the option worked for me, feel free to improvise as the options are pretty simple to understand.

 

Now thermaltake please fix this problem on your software, is not that hard to implement a reboot sequence. Right now my solution is like i'm taking a crap and realise there are no toilet paper, so i have to get up and grab some from the living room and then wipe my but. 

Share this post


Link to post
Share on other sites

Thank you for this.  I am not sure why this isn't getting more attention. 

I am very disappointed in the product because of the ridiculously poor software/hardware (controller) design.  The posts on this forum (ThermalMike) that users should shut down their computer, change bios/EFI settings, buy different hardware (implied), or develop their own fix is inexcusable.

Where is the fix for this? 

As mindPreBlown suggests, we can fix this ourselves as the consumer.  But that is absolutely ridiculous. I am still weighing whether I should write a script for this (I would prefer PowerShell) or just return it.

To quote ThermalMike:

"Hi,

Unfortunately a limitation of the MB USB 2.0 header. Check to see if you can do a different sleep mode that does not disable the 5V.

Basically when the system goes to sleep it drops connection to the controller, therefore you have to reboot the software for it to reconnect."

Mike, I would disagree from a consumer point of view. You are blaming what was something that should have easily been uncovered through testing before you shipped the product.

I perceive this as 1) a limitation of your own software and/or 2) a limitation of your controller.  I have a View 32 case and the cheaper controller saves state fine with no software whatsoever.  Regardless, in this era at this price point, I expect your gear to work as advertised with standard computer features like sleep.

Quite frankly, I am surprised I just dropped $300 on hardware from you guys to only be met with comments like I should shut down my computer instead of using sleep. 

Honest questions: Why do you a) not save state on the controller itself? or b) develop software to reconnect to your own controller after sleep? 

While you cannot roll back time and fix the hardware, fixing this in software seems to be a few lines of code.   You have spent more time on the forums than it would take to write the fix.

Does.not.compute.

Edited by tech007
less rant-ish - more succint

Share this post


Link to post
Share on other sites

@kewlmunky - thanks for that info, I will reach out to them.

In other news, I ended up making a fix today that works without really any coding (other than copy/paste) using Task Scheduler.

  1. In Task Scheduler, create a new Task - call it whatever you want, I called mine "Thermaltake"
  2. Under the Triggers tab, create a new trigger and select "On an event"
  3. Select Custom and then Edit Event Filter... 
  4. Under the XML tab, click the checkbox to Edit query manually then enter <QueryList>
      <Query Id="0" Path="System">
        <Select Path="System">*[System[Provider[@Name='Microsoft-Windows-Power-Troubleshooter'] and (Level=4 or Level=0) and (EventID=1)]]</Select>
      </Query>
    </QueryList>
  5. The only option I have selected under Advanced is "Enabled"
  6. Under Actions you will create two.  For the first one, create an action to "Start a program" and under Program/script enter taskkill - this closes the running instance
  7. In the Add arguments field enter /f /im "TT RGB Plus.exe" - this targets the app itself, if it doesn't work make sure you have the right process here
  8. Click OK and add another action
  9. For the program/script, browse to where your TT software is installed, mine is "C:\Program Files (x86)\Tt\TT RGB Plus\TT RGB Plus.exe" - this should be the same as step 7

A few other nits:

  1. Not sure if needed, but under Settings I have "Allow task to be run on demand" checked, this way I could run it to test before doing a sleep test
  2. I have "If the running task does not end when requested, force it to stop" checked
  3. And finally, I have set "If the task is already running, then the following rule applies:" set to Stop the existing instance

Probably sounds more complicated than it is.  Only takes a minute to set this up.  It will be saved under Task Scheduler Library in case you need to tweak it.  I have tested it and it seems to work well. Once you log back in or otherwise wake from sleep you should see the TT program quit then reopen.  The only issue I see is the ghost tray icons which show in the bottom right of my task bar till I mouse over them.  

 TT if you read this, this is why I am frustrated with you guys.  You could have easily done this yourselves in many different ways.  If there is indeed an updated cable I will got that route as it would seem like a better solve.

Share this post


Link to post
Share on other sites
On 11/3/2018 at 10:31 AM, tech007 said:

@kewlmunky - thanks for that info, I will reach out to them.

In other news, I ended up making a fix today that works without really any coding (other than copy/paste) using Task Scheduler.

  1. In Task Scheduler, create a new Task - call it whatever you want, I called mine "Thermaltake"
  2. Under the Triggers tab, create a new trigger and select "On an event"
  3. Select Custom and then Edit Event Filter... 
  4. Under the XML tab, click the checkbox to Edit query manually then enter <QueryList>
      <Query Id="0" Path="System">
        <Select Path="System">*[System[Provider[@Name='Microsoft-Windows-Power-Troubleshooter'] and (Level=4 or Level=0) and (EventID=1)]]</Select>
      </Query>
    </QueryList>
  5. The only option I have selected under Advanced is "Enabled"
  6. Under Actions you will create two.  For the first one, create an action to "Start a program" and under Program/script enter taskkill - this closes the running instance
  7. In the Add arguments field enter /f /im "TT RGB Plus.exe" - this targets the app itself, if it doesn't work make sure you have the right process here
  8. Click OK and add another action
  9. For the program/script, browse to where your TT software is installed, mine is "C:\Program Files (x86)\Tt\TT RGB Plus\TT RGB Plus.exe" - this should be the same as step 7

A few other nits:

  1. Not sure if needed, but under Settings I have "Allow task to be run on demand" checked, this way I could run it to test before doing a sleep test
  2. I have "If the running task does not end when requested, force it to stop" checked
  3. And finally, I have set "If the task is already running, then the following rule applies:" set to Stop the existing instance

Probably sounds more complicated than it is.  Only takes a minute to set this up.  It will be saved under Task Scheduler Library in case you need to tweak it.  I have tested it and it seems to work well. Once you log back in or otherwise wake from sleep you should see the TT program quit then reopen.  The only issue I see is the ghost tray icons which show in the bottom right of my task bar till I mouse over them.  

 TT if you read this, this is why I am frustrated with you guys.  You could have easily done this yourselves in many different ways.  If there is indeed an updated cable I will got that route as it would seem like a better solve.

THANK YOU. This worked great for me. 

Share this post


Link to post
Share on other sites

I tired both of these options, and neither one works for me. :(

I wish I had realized this issue before I purchased it or would have gone with another brand.  Especially after seeing ThermalMike's response, I'll never buy another Thermal Take product. That's completely unacceptable. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×