Jump to content
  • Forum Statistics

    6.6k
    Total Topics
    44.6k
    Total Posts
  • Member Statistics

    88,434
    Total Members
    16,800
    Most Online
    xeans
    Newest Member
    xeans
    Joined

TT CPM

Moderator Thermaltake
  • Posts

    339
  • Joined

  • Last visited

  • Days Won

    14

Everything posted by TT CPM

  1. Hi, Sorry for the inconvenience, I think the AIO is defective, you may contact our customer service for RMA.
  2. Hi, Water 3.0 ARGB series AIOs only work with motherboard RGB software or the little controller that comes with the AIO. It can not connect with Corsair's controller.
  3. Hi, For socket compatibility, yes, Floe Ring RGB 280 AIO can fit it.
  4. Hi, Water 3.0 series AIOs do not support threadripper CPU. You may consider Floe Riing RGB TR4 AO
  5. Hi, Here is the link https://www.thermaltakeusa.com/pacific-core-p5-dp-d5-plus.html
  6. Hi, TT RGB PLUS now is 1.4.2, it should solve the issue. https://www.thermaltake.com/downloads
  7. Hi, the 8 pure plus fans are all connected to TT sync controller right? If correct, it can not be controlled by RGB plus software once you plug the fans to tt sync controller. TT sync controller is designed for motherboard rgb software.
  8. Hi, It sounds like a RMA issue, you may contact our customer service.
  9. Hi, The fans with the AIO can not be controlled by RGB PLUS software, they are not software based fans. You can try GBT's RGB software, just make sure you connect the fans to 5V ARGB header.
  10. Hi, Fan with Water 3.0 120 ARGB is PWM, TH120 is fixed speed, it depends on if you need a PWM fan.
  11. Hi, Can you check if the power cable connect properly?
  12. Hi TT RGB PLUS software only supports Thermaltake products, It can not control T-Force memory.
  13. It could be a sensor malfunction, you may contact our customer service.
  14. Hi, The controller in amazon link is designed for LED strip, it can not control the analog RGB fans, we have upgraded all our RGB fans to 9pin software controlled.
  15. Hi, Thanks for your feedback, I will report it to our team for future update.
  16. Hi, Could you help to check is the system temp is going up? Or just the LEDs was not working? If the issue is the LED, please msg me your email and contact info, our CSD will contact you soon.
  17. Hi, Sorry for the inconvenience, our warranty is 2 years.
  18. Hi, It looks like the LEDs on pump is defective, please msg me your email and contact info.
  19. Hi, We actually tested the update last week, it worked fine. Our software team will contact Razer today see if they change anything after they sent the update to us.
  20. Hi, T1000 and C1000 are base on different formula, do not suggest to mix it.
  21. Hi, LEDs on pump not working? ok, please msg me your contact info.
×
×
  • Create New...