Jump to content

TT RGB PLUS 1.4.0 (1.3.9&1.3.7) with Ring Quad 12 (ONLY SOMETIMES WORKS PROPERLY) WIDEO


fr3sh
 Share

Recommended Posts

So I'm little be disapointed on this product. Every one has the same issue with it and they are not respond. Even on the forum no solution for the customers.

Here is how to looks like in my case sometimes. The Ring Quads are not found in the system 

MY SETUP:

MATHERBOARD: TRX40 AORUS XTREME (rev. 1.0)
PROCESSOR: Ryzen Threadripper 3970X
Ram G-Skill Trodent- X 128Gb
POWER SUPLY: Corsair i1600W
Thermal Take Ring Quad 12
DYSKS: SSD MP6000

RESULT:

WIDEO

see also the attachment files. 

The wideo can help you only workaround to the issue.

No matter how you're controllers will set up. No matter how your controller be plug in and where. I have tryied so many different scenarios.  

Sometimes they are working and sometimes they dont with no reason at all. And default ring color on boot when you set up profile 
is making this product not on 21th century. I wish I knew these before buying

 

My  .50 cent on this crap product.

Sadly it's a waste of money. If they be honest then they should refund this product for customers asap and 
say something that they screw this up.
 

TT release the software to public. Internet will fix you the software issues if you cant do it properly in tree releases. 

IMG_20210227_120556.jpg

IMG_20210227_111251.jpg

IMG_20210227_123334.jpg

Link to comment
Share on other sites

get used to it.. I RMA'd half a half dozen controllers after a month or so they stop working, return them asap. Might be a AMD issue I dk but their software is #### I will never buy another thermaltake item again. I can't even sell them to other people at this point! I got 15 rainbow puke rgb fans now on a threadripper that half #### works.

Link to comment
Share on other sites

A friend of mine who owns an X570 Aorus Xtreme with a 3900X CPU, nothing worked I even lent him my Riing Trio controllers but still to no avail.

When he tested the fans on an old motherboard he had from like 7 or 8 years ago it all worked well.

He also tried it on a relative PC that worked fine.

My guess is that there is something not working between Aorus firmware/bios and Thermaltake firmware.

He then switched to Corsair QL fans and he is so happy and regrets buying the Quad fans.

----------------------------------

Thermaltake support takes weeks to answer, their mods like stealth mode on the forum, their whole marketing is focused on selling the product and to #### with the customer after the sale happens.

Lesson learned~

Link to comment
Share on other sites

  • 3 weeks later...
On 2/27/2021 at 8:57 PM, fr3sh said:

So I'm little be disapointed on this product. Every one has the same issue with it and they are not respond. Even on the forum no solution for the customers.

Here is how to looks like in my case sometimes. The Ring Quads are not found in the system 

MY SETUP:

MATHERBOARD: TRX40 AORUS XTREME (rev. 1.0)
PROCESSOR: Ryzen Threadripper 3970X
Ram G-Skill Trodent- X 128Gb
POWER SUPLY: Corsair i1600W
Thermal Take Ring Quad 12
DYSKS: SSD MP6000

RESULT:

WIDEO

see also the attachment files. 

The wideo can help you only workaround to the issue.

No matter how you're controllers will set up. No matter how your controller be plug in and where. I have tryied so many different scenarios.  

Sometimes they are working and sometimes they dont with no reason at all. And default ring color on boot when you set up profile 
is making this product not on 21th century. I wish I knew these before buying

 

My  .50 cent on this crap product.

Sadly it's a waste of money. If they be honest then they should refund this product for customers asap and 
say something that they screw this up.
 

TT release the software to public. Internet will fix you the software issues if you cant do it properly in tree releases. 

IMG_20210227_120556.jpg

IMG_20210227_111251.jpg

IMG_20210227_123334.jpg

Dear User

Thank you for ur report, Could you provide the log file to us.

Following the tips below this link.

https://www.dropbox.com/s/f4vu78intz2bbdi/TT RGB PLUS Debug Mode.docx?dl=0

Link to comment
Share on other sites

  • 2 weeks later...
On 2/27/2021 at 6:27 PM, fr3sh said:

 

TT release the software to public. Internet will fix you the software issues if you cant do it properly in tree releases. 

 

Allahualam. I second that. TT should release their software to the public. It would be better for them as well as the users.

Link to comment
Share on other sites

On 3/5/2021 at 10:20 PM, Vinasis said:

A friend of mine who owns an X570 Aorus Xtreme with a 3900X CPU, nothing worked I even lent him my Riing Trio controllers but still to no avail.

When he tested the fans on an old motherboard he had from like 7 or 8 years ago it all worked well.

He also tried it on a relative PC that worked fine.

Even I have a (gigabyte) motherboard that I got in mid 2014 that makes it around 7 yrs old now!

So, from your comment I believe I may not face troubles using Riing Quad fans on this mobo of mine.

Based on this info I have ordered for the riing quads which is yet to be delivered. Lets hope alls fine. I will post about it when I have them.

Link to comment
Share on other sites

On 3/24/2021 at 9:18 AM, Tony.P said:

Dear User

Thank you for ur report, Could you provide the log file to us.

Following the tips below this link.

https://www.dropbox.com/s/f4vu78intz2bbdi/TT RGB PLUS Debug Mode.docx?dl=0

Tony.P this is imposible to do what you are tying to do because the controlers are not visiblie in the system. Running the program with debug mode will open a program with 

the notification visible below and not store the logs because of not visible controlers on the system! 

image.thumb.png.1877158b88bfbdcf7f1a575feb4e5f8b.png

 

Moving Forward I will turn it off one controler and on from the conflicted system manager

image.thumb.png.7f76ad7c69c6b686a007ba0cc8d58a11.png

Now it's more interesting but still no logs!

image.thumb.png.1b284c9060a1853be5569d3ec4aadead.png

last test with two controllers working on the system manager shows the same as above screen with the message. Still no logs!

Link to comment
Share on other sites

  • 4 weeks later...

I got with TT not too long ago they sent me 2 more controllers, and so far they working. What I understand they are working on new software, maybe they can assign different controllers to temps sensors for those of us that have 2 loops. Support has been very understanding. That being said there are a few ways to bypass the controller itself and use a custom controller. Youtube has a video that has the proprietary pinout explained.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...
On 7/10/2021 at 5:36 AM, fr3sh said:

Any news?

Dear user

After testing, it's regretted that problem is only on the AMD platform.

Our team suggest that update BIOS to FBi and Windows to 21H1 will temporarily resolve the problem. 

Thank you for your report.

Link to comment
Share on other sites

On 7/15/2021 at 11:54 AM, Tony.P said:

Dear user

After testing, it's regretted that problem is only on the AMD platform.

Our team suggest that update BIOS to FBi and Windows to 21H1 will temporarily resolve the problem. 

Thank you for your report.

Im on rev.1.0 of the motherboard so I have F4q bios its the same as FBI.

I have this bios updated 3 months already and nothing was changed. I will try to update windows to 21H1 but I don't think so it will help. 

Could you please share what is the problem with AMD platform?  

If you are aware of the problem now how can I return this FANS if they are not working for me corectly.

I want to belive it you are good company. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...