Jump to content

Software cant recognize the new Riing 12 RGB Fan TT Premium Fans.


Recommended Posts

I recently bought the Riing 12 RGB Fan TT Premium Fan pack.

I have installed the fans in case connected each fan to the hub, connected to molex and connected it to my motherboard using usb 2.0 connection.

After installing the software, i noticed none of the fans are being recognized by the software. 


I have un installed the software, connected to a different usb connection, only connected 1 fan on the hub, even changed my entire ssd, still the fans are not being recognized by the software.


Though my motherboard is new i thought it was the usb connection fault, so i tried the nzxt hue + lightning kit on both connections and it worked and i can control it form my pc.


Should i return the fans or is there any other trouble shooting i can do.

Please leve your suggestions 




Link to comment
Share on other sites



Thanks for the post so we can assist.


What are your system specs and OS?



We have some new videos going through the setup and then the software here:






Check it out and see if that might help.

Make sure the power is connected directly into the PSU, no adapters and such. Do not unplug and reconnect while the system is on and running to avoid damage to the controller.


Call our support team to open a ticket and we can swap the controller out to see if that clears up the issue if nothing else works.

Link to comment
Share on other sites

I have windows 10 as OS


System specs

i5 6500, 16gb ddr4 RAM, 960 gb SSD, Asrock b150/k4 motherboard, 650 w Bronze Fractal PSU, EVGA GTX 1070 FTW.


I have always turned off the computer and plugged the fans or unplugged them.


Still the software seems to not recognize the fans

Link to comment
Share on other sites



Are you using the latest version of the software?


Download here:



This is the same version I am using in the videos.


If the controller is non responsive and you have reinstalled the software and checked the connections it may be defective.


Contact our support to troubleshoot further on this and we can swap out the controller for you under warranty to see if that resolves the issue.


Contact info in my sig below.


Keep us posted.

Link to comment
Share on other sites

  • 2 months later...
  • 4 months later...
On 2016-12-24 at 7:18 AM, Kervin Aquino said:

I have the same issue. My Tt Riing 140mm RGB premium edition cant be detected by the software also. Been reinstalling the software many times and its weird that everytime i have installed the software. my PC crashes. How can I request for a new controller? im from Philippines.
PC specs:
Windows 10
i5 6600k
gtx 1060
8gb ram

Kervin Aquino. I had exactly the same issue as you. It was a software problem. I downloaded the software for the 'Riing Premium Edition' instead of the 'Premium PLUS Edition' which I suppose is the fan you bought. Here is the link for the latest driver:


Let me know if you managed to fix the problem. 

Link to comment
Share on other sites

  • 1 month later...

I've had mine for about two months. I had the original software it came with, and had no real trouble setting it up. (the gui didn't like hi res monitor). I was able to change fan speeds, performance, silent, and program the colors to red. I have these on one side of my radiator in a push pull config and had them on silent. It's been at least two weeks since i made any adjustments on them, but this time the software says the controller isn't there. Fans don't show up either. I noticed a software update on your site. Tried that with no success. Just a fancy message now that says Controller not found. I've tried uninstalling and reinstalling software, multiple USB headers on the mobo, different micro usb cables, even tried connecting the controller to an external usb port. still nothing. 

I have no idea how long the controller may have been out. I guess I never thought anything was wrong because the LED's are the same color I set, and the fans are still spinning. 


Attached pics of before and after update. These are the Riing premium radiator 12mm fans 


Windows 10 pro, Z170i Gaming Pro AC mobo, gtx 1080, 7700k, 16gb gsklllz ripsaw, 960 evo pro nvme ssd 



Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Hello everyone,

When i use the "Riing Plus RGB Tt Premium edition" software i also get the "Do not find Fan controller, please check the fan controller is connected H_0x0001" Error. When i use the "Riing RGB Tt Premium edition" software it does not give me an error but it just tells me the fans aint spinning, and every change i make to the color or whatever does not work on the fans.

Can anyone tell me how to fix this ? my fan's are spinning and the default color red is on. also when i replug the microUSB cable into the controller windows tells me a device is detected.



Update: I just downloaded a newer version of the software here:
Unfortunately this version doesn't even seem to start (i did uninstall the other software first) so my problem still stands.

Edited by GvdMeijde
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

-Hi guys, I am having the same issue.  Tried Both software, uninstalled and reinstalled.  The Riing RGB Radiator Fan TT Premium Edition runs but I get the same error code as the guy above.  The Tt\Riing Plus RGB Tt Premium Edition runs as a task but cant get the control panel up.  I Previously has CorSair fans and wanted to go with thermaltake but had no idea there were such software issues.  I will be calling tech support later today but this SHOULD be something that works right out of the box.  I am not liking this buggyness that i have to play with on a brand new system.    Any help is appreciated.

Link to comment
Share on other sites

  • 4 weeks later...


having a issue to get my Riing 14 Radiator Fan TT Premium Edition to run.

The only thing I get when starting the Software is an errormasage:

Can't find controller

Checked several usb connectors on my board.

Error allways stays the same.

Please help. Bought them 03.24.2017. Seems that the controller is defectiv.

THX guys  


Link to comment
Share on other sites


I'm using 3 Riing Plus Controllers, daisy-chained via the USB extension cables. with 12 devices (fans & pumps). The dasiy chain cables being way to short to span the width of my Core P7 case, I hat to extend the cables.


The on-board double USB 2.0 connectors of my Gigabyte X399 (Threadripper 1950X) didn't work at all, so I used a rear USB 2.0 port with a USB micro cable.

After the system starts, I have to unplug an replug each controller from the Molex 5/12V power cable, in order for the Riing Plus Software (v 1.1.3) to find the controllers.

Then everything works fine.

It seems to be a design issue with the controllers, if power comes from USB and the power plug simultaneously, they behave erratically.

My pramgmatic solution: I built a delay module, that delays the 5V and 12V going to the Riing Plus controllers by 2 seconds when the PC starts.


The Riing Plus RGB TtPremium Edition Software sees all 12 devices on system startup!


Now  I'm happy.

But Thermaltake should really work on this issue.

By the way, the 3-button RGB controllers for the Pacific RGB fittings should be upgraded, so they can also be controlled from the Riing Plus software.






Link to comment
Share on other sites

Hi Mental, 

thanks for the feedback and nice job on the rework, I can see you planned that out pretty well. 

It is not an issue with the controller exactly, it is more with what IC that was used on the new AMD boards that we could not have planned for as they ended up different from previous gen products. This was also changed not just from intel, but AMD's previous line as well.

To resolve this compatibility change, we have a replacement controller specifically for AMD to solve this issue. 

Please contact our support in your region for details on how to get a replacement. 

The new controller should solve the issue and function properly. 

Link to comment
Share on other sites

Hello. Just bought the floe ring 240 and I have everything hooked up. In the software, I cannot get the fans set up, as the software only recognizes their leds and thinks that they are pumps. I've attached a video of what happens when I try to add the fans in the software. The fans are only lighting up and not spinning. Not sure what to do at this point 


Link to comment
Share on other sites



Thanks for the video, hard to see some stuff, but I think I have an idea.

1. Confirm which part is plugged into what port on the controller. (You should know which one is for the pump 1-5)

2. When you select it on fan and it goes red, that means you are selecting something that is not what it is. Confirm where everything is plugged in will help I think. You can unplug the pump to play with just the fans, takes a little to understand how it works, we have videos on youtube :)

3. Once you have it setup, you can copy color the LED features and for the fan speeds you just need to set PWM on/off and what mode you want it to be in.

If the software continues to do this, uninstall it and reinstall and check your connections.

Keep us posted or contact our support in your region for assistance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...