Jump to content

Recommended Posts

Hello everyone, the two front 200mm fans on my case have stopped working, the top one works fine i even plugged the top fan into the other fan controller port and still works, i plugged the fan into the motherboard and it barely ran and the light was very dim, everything is plugged in correctly but both fans don't work, is the fan broken or is something else broken? any help is welcome 

thanks

Micheal

Share this post


Link to post
Share on other sites

Can someone please tell me how thick the window is in mm. I'm at work and don't have access right now. I need to know what length the screws need to be before I order.

the thickness of the window is 3mm

Share this post


Link to post
Share on other sites
nrj    0

Hey guys,

 

Sorry if this is a bit off topic, but has any of you figured out how to change the default chassis fan speed for Core V71 to low?

 

I don't like pressing on the Low button every time I start my computer.

 

Thanks for your help!

Share this post


Link to post
Share on other sites

Hi guys, I just got the case from Newegg last week.  

Love the design.

The only thing I'm having problem with is the capacitor on the fan control PCB exploded right after I turn on the power. The connections are so easy that just can't be wrong. Have any body had same problem before? I would definitely appreciate some help. 

post-2071-0-23332400-1417409383_thumb.jpg

Share this post


Link to post
Share on other sites

Hello Charles, 

 

I think the best option would be to get it replaced,

please give our team over in USA a call or mail

Sorry for any inconvenience this may have caused

 

By Email:           support@thermaltakeusa.com

 

By Phone:          Toll-Free 800-988-1088

 

 M-F 9:00AM – 5:30PM (P.S.T)

 

Share this post


Link to post
Share on other sites

i also have a problem with the PCB. LED on/off switch doesnt work properly. LEDs are all on when i first power up the computer as usual but when i turn them off i just cant get them on again. LEDs are flashing once as i press the button.

 

since im from Turkey and dont even have a turkish website, i dont know where to go what to do. :( Any suggestions TT Andy?

 

i have setup the computer already, so is it possible for me to receive just a new PCB from thermaltake instead of replacing the whole case?

 

thanks

Share this post


Link to post
Share on other sites

i also have a problem with the PCB. LED on/off switch doesnt work properly. LEDs are all on when i first power up the computer as usual but when i turn them off i just cant get them on again. LEDs are flashing once as i press the button.

 

since im from Turkey and dont even have a turkish website, i dont know where to go what to do. :( Any suggestions TT Andy?

 

i have setup the computer already, so is it possible for me to receive just a new PCB from thermaltake instead of replacing the whole case?

 

thanks

Hello Saracg,

 

Since you are in Turkey,

I think the fastest way would be to contact the re-seller in your area first and see if they can replace that part for you,

otherwise you can contact our distributor or our customer service

Share this post


Link to post
Share on other sites

Hi guys! I bought the V71 a few months back and have finally finished purchasing all the parts for my build, they are due to arrive today! Here is my build, what do you guys think?

 

Motherboard: Asus Rampage IV Black Edition

CPU: i7 4930K

GPU: MSI NVIDIA GTX 980 Gaming

RAM: G Skill 2x 8GB PC3-19200 DDR3 2400MHz Gaming Memory Kit

Cooling: Corsair CW-9060014-WW Hydro Series H110 AIO

PSU: XFX ProSeries (Black Edition) 750W Fully Modular 80+ Gold Power Supply

HDD: Samsung 840 EVO 250GB SSD

Monitor: Asus PB287Q 28 inch Widescreen Ultra HD 4K LED Monitor

 

I will be using it as my design rig so will be building a Hackintosh, with some gaming on the side via Win 8.1 ;)

 

Share this post


Link to post
Share on other sites

Hi guys! I bought the V71 a few months back and have finally finished purchasing all the parts for my build, they are due to arrive today! Here is my build, what do you guys think?

 

Motherboard: Asus Rampage IV Black Edition

CPU: i7 4930K

GPU: MSI NVIDIA GTX 980 Gaming

RAM: G Skill 2x 8GB PC3-19200 DDR3 2400MHz Gaming Memory Kit

Cooling: Corsair CW-9060014-WW Hydro Series H110 AIO

PSU: XFX ProSeries (Black Edition) 750W Fully Modular 80+ Gold Power Supply

HDD: Samsung 840 EVO 250GB SSD

Monitor: Asus PB287Q 28 inch Widescreen Ultra HD 4K LED Monitor

 

I will be using it as my design rig so will be building a Hackintosh, with some gaming on the side via Win 8.1 ;)

Hi, Looks great same motherboard as me, you might consider a matched quad channel ram kit as the 2x 8gb kit you have will only work in dual channel mode, your motherboard is best with quad channel ram but it should still work fine in dual channel mode., enjoy that awesome Core V71 it's a great case it's a hot summer here and my two gtx780s never get over 65c after hours of playing bf4☺

Share this post


Link to post
Share on other sites

Hi, Looks great same motherboard as me, you might consider a matched quad channel ram kit as the 2x 8gb kit you have will only work in dual channel mode, your motherboard is best with quad channel ram but it should still work fine in dual channel mode., enjoy that awesome Core V71 it's a great case it's a hot summer here and my two gtx780s never get over 65c after hours of playing bf4☺

I finally got all my parts, unfortunately the motherboard wasn't working. I finally got a replacement and guess what, it was the Rampage IV extreme instead of black! I am using it until I receive another replacement, sigh!

 

I've managed to get a Hackintosh working almost flawlessly so far, with a geek bench score of just over 25,000 for multicore!

I have managed an overclock of 4.5GHz at 1.4V but it seems to be heating up reaching 78 and peaking at 80C during geek bench stress test. Is that too high? I mounted the H110 on top, replacing the 120mm fan that came with the V71. I have it blowing air out, I am considering trying it inhaling instead, what do you think?

 

Also, thank you for the RAM recommendation! I will just get another 16gb kit when I have the funds :D

 

So far everything works so fast, the system boots up in mere seconds, and thats including opening up everything I had opened previously. 

I have been web designing on a 2008 macbook for over a year and I feel godly in comparison now!

Share this post


Link to post
Share on other sites

Hi, had this case for about 5 months now and still loving it, its a very hot 30c+ New Zealand summer here and its doing a fantastic job of cooling my 2x780s and Asus Rampage IV Black Edition motherboard well worth the cost compared to the  more expensive brands that cant compete in the air-cooling area, believe me i have tried a fair view cases in the past few years and this case is perfect for me :)

But unfortunately today i was cleaning the dust from the front filter and with my clumsy man hands i put a hole in the mesh, would it be possible to get a replacement front dust filter?

Share this post


Link to post
Share on other sites

Hi, had this case for about 5 months now and still loving it, its a very hot 30c+ New Zealand summer here and its doing a fantastic job of cooling my 2x780s and Asus Rampage IV Black Edition motherboard well worth the cost compared to the  more expensive brands that cant compete in the air-cooling area, believe me i have tried a fair view cases in the past few years and this case is perfect for me :)

But unfortunately today i was cleaning the dust from the front filter and with my clumsy man hands i put a hole in the mesh, would it be possible to get a replacement front dust filter?

Zimzoid,

 

Please contact your local distributor they should be able to help you get a replacement, or you can contact our customer service, there will be people helping you out directly.

Here is the website for our customer service: http://my.thermaltake.com/csWarranty.aspx

 

Please let me know if you have any problem on getting the replacement.

Share this post


Link to post
Share on other sites

Hi everyone

Loving the Core V71, So big and moves so much air.

Just a question is there enough space to put an X61 AIO water cooler with push/pull on the top of the case with both 200mm fans up there as well?

i was thinking of putting one there with 4 Thermaltake Riing fans above the motherboard and leaving the 2 200mm fans in the top

is this possible?

thanks

Micheal

Share this post


Link to post
Share on other sites

Hi everyone

Loving the Core V71, So big and moves so much air.

Just a question is there enough space to put an X61 AIO water cooler with push/pull on the top of the case with both 200mm fans up there as well?

i was thinking of putting one there with 4 Thermaltake Riing fans above the motherboard and leaving the 2 200mm fans in the top

is this possible?

thanks

Micheal

 

Welcome to the community of Core V71.

 

to answer your question:

Core V71 has a 42mm distance from the edge of MB tray to the inside of top panel, and with X61 that has a thickness of 27mm without the fans. It would not be possible to do a push and pull when the fan has a thickness of 25mm. You may get by with either push or pull and still keeps the 200mm on top, but it really depends on the motherboard you are using.

Share this post


Link to post
Share on other sites

Would someone explain me what is the function of the indicator in the front panel? It is constantly blinking (orange/red). Is it supposed to be so? I think initially it wasn't blinking and was solid blue.

26032015091JPG9Aoxqqv_sredna.jpg

Share this post


Link to post
Share on other sites

Hi, 

 

I received this case and finished my build around 5 days ago, but I am having trouble with the 3 case fans when using the control panel on the top.  I just cant get the fans to work when they are plugged into the top control panel.  I have unplugged them, and plugged them directly into my motherboard and they work perfectly fine.  Am I doing something wrong when they are plugged into the control panel, or do you think there is something wrong with the connections on the panel?  The reset button and the HDD led work fine on that portion though, if that helps at all.\

 

Any help would be greatly appreciated, thank you.

Share this post


Link to post
Share on other sites

Hi, 

 

I received this case and finished my build around 5 days ago, but I am having trouble with the 3 case fans when using the control panel on the top.  I just cant get the fans to work when they are plugged into the top control panel.  I have unplugged them, and plugged them directly into my motherboard and they work perfectly fine.  Am I doing something wrong when they are plugged into the control panel, or do you think there is something wrong with the connections on the panel?  The reset button and the HDD led work fine on that portion though, if that helps at all.\

 

Any help would be greatly appreciated, thank you.

 

The fan speed and light controller are only compatible with built in 200mm LED fans. If you are having issue on our built in fan with the controller, please contact our customer support.

 

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

Share this post


Link to post
Share on other sites

The fan speed and light controller are only compatible with built in 200mm LED fans. If you are having issue on our built in fan with the controller, please contact our customer support.

 

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

Thank you, I probably will.

Share this post


Link to post
Share on other sites

So I have owned this chassis for quite some time now, and I recently bought another 200mm fan along with two 120mm fans so that I can add them in. I bought a fan controller for them and they work with it just fine, but when I try to switch the three 200mm fans over to the controller, they are very dim and the fan speeds are low. Does anyone know how I can fix this?

 

I should mention that I bought a new touchscreen fan controller. And those original three fans are the only ones that don't work correctly with it.

Share this post


Link to post
Share on other sites

Hello all, 

This is only partially a V71 Question...

I have a Chaser MK-I and am switching to watercooling. The factory fan in the door is no longer necessary, and I would love to have more viewing window.

From what I've been able to figure from pics, the "bones" of these chassis look really similar.

Can I use the door from the V71? ... and where do I order one?

Thanks in advance!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×