Jump to content
Zeonymous

TT RGB Plus Freezing/Unresponsive

Recommended Posts

Since the day I have had this software installed, it has been causing a lot of problems.
It'####-or-miss, and I've spent a good amount of time over the past 3 months, looking for solutions.

Problem;
The TT software freezes, normally almost immediately after a reboot, say 2-3 min, or anywhere between a half an hour, or an undetermined amount of time.
Sometimes it just doesn't crash at all.

The biggest givaway, is the the RGB controls, for most notably, the first controller, and the PSU fall off.
When this lockup happens, the controls for fan speed for the first controller are non-functioning.


image.thumb.png.6c51e229c20c7926bca8114db2bf2f82.png
Attached is an example of the fan speeds pulled down to silent (Which in a normal case would dip the speeds to sub 1,000 RPM.
The whole time I have been typing this, this has been the case, with the fans clearly not responding to the app.

During this time, the TT DPSG App is no longer synced to the TT RGB Plus app, and is using it's fallback RGB setting.
I believe it's fan speed is being controlled directly by the DPS G app, itself.

I'll underscore this noting that the issue I have lies with the TT RGB Plus software, and not the DPS G software.
I do have a slight DPS G issue (Running 2 instances on any reboot, one with RBG controls, and one without)

In this instance, the second DPS G is closed, the one without the RBG control.

Edit/Update;
Closing, and restarting the program in this unresponsive state resets the slider to performance, but enables control, real-time RPM updates, and RGB on controller 1, and the PSU again, until next lock-up.
Basically, this is the only way I can get the program to behave as intended, and am wondering if I am missing something terribly obvious. The constant closing (As typing this out it locked up again) is a real problem.

Edit2;
DPS G has resolved it's issue via an updated.
TTRGBPlus still having issues.

Share this post


Link to post
Share on other sites

image.thumb.png.4d480820e1412c0af694d2b49ca45216.png
New problems! Now frozen on startup!

Synopsis this time; The app is frozen, but the rings are doing the default dance, slow and wave.
The flow ring's colors are a mess. Like just all broken up, still in wave mode, but going through what seems to be fan 1's colors, (12 colors) on the 6 color node, and all piling up at 3/s node.
Completely unresponsive. I wouldn't be surprised if this ####-aweful app was causing damage to my $5000 PC.
I don't trust this BULLSHIT, and if I get banned off of this forum for saying so, at least that would give me SOME indication that the support team is HARD at work here.

Share this post


Link to post
Share on other sites

Okay guys, if you're having this issue... I MAY have found a workaround.
Bear with me, it's not as simple as "Just fix it, and it will boot fine and remain stable on every boot..."
 

So, all you have to do which has yielded me the MOST success, is when you start the program, freshly...

  1. Restart the program (Force close if it's stuck in the Task Manager)
  2. Change your "Profile" on your controller(s) to a different profile.
    1.  You can change back to the previous profile after you switch.
  3. SAVE controller(s) to the desired profiles.
  4. Continue on with your life, hopefully.

This is the process I have found yeilds the best results in terms of stability.
I'm not sure what causes the crashes, but whatever it is seems to be reliant on the current profiled being that of a 'ghost' profile, which may be causing the lockup.
I hope this works for anyone else, as it is not the ideal solution, but it is the only one I have afforded myself, as I have gotten no response from the community to express otherwise.

I'll pop back in here with any findings, and if anyone has anything to add, such as saving a config file to force the load, or running some other method to expedite this process on startup, feel free.

Share this post


Link to post
Share on other sites

let me know if you find a fix, for some odd reason, other then one of the newer versions, the TT RGB software freezes up my computer on start up? nothing with work and have to hard re start into safe mode to unistall software.

 

it worked fine for about 3 months and i have no new hardware but somthing is not liking TT RGB.

Share this post


Link to post
Share on other sites

Found one!

Okay, its super dumb, but here's what you have to do;

When you boot up your system, you take these steps:

  1. Launch the software (Not sure if it needs to be a fresh launch or not)
    [Edit In: If your RGB Plus software is frozen, close it. If it IS closed, and not in your taskbar, kill it forcibly in Task Manager]
    [I am also launching as Administrator]
  2. Literally click SAVE like a MILLION freaking times while flipping back and fourth through profiles
  3. Finish out on your desired profile and Click SAVE like A MILLION more times.
  4. ????
  5. Profit!

Seriously.

I did the "Click Save" a few times, and it ended up not working every time, but if I did the above steps, I don't know if it 'warms up' the program or something, but it's the most stable it's ever been.
I'm 2 for 2 between 2 system restarts over 4 days or so.

I'm actually kind of upset that this was the solution, because it doesn't just work..

If anyone at Thermaltake sees this, I'm running on a Threadripper 2950x, RTX 2080Ti, with your own iRGB Plus 1200W PSU, and a MSI CREATION motherboard, (16GB 3600mhz G.Skill Ram 2x8)

If you wanted, you could theoretically build my config and replicate the problem.

Running 2 controllers, with 7 fans and your own AIO Plus pump.

Make hit happen. I defeated your software, now do me the solid of doing your job.

Kthxbai.

Share this post


Link to post
Share on other sites

Update;

Something strange is happening, even though it's running, and responsive.
There's some kind of 'stutter' in the RGB. Is it a short in the controller that had caused this problem all along?
Is it the fact that my DPSG just lost it's mind like 10min ago telling me during a YT video that it wasn't plugged in correctly?

All this and more on the next episode of "THERMALTAKE ACTUALLY CARES ABOUT IT'S CUSTOMERS!"

[Airing 1/1/3041]

#### Lol...

So, DPSG was closed!
I restarted DPS G (NOT SYNCED, MIND YOU) and it cause the TT RGB Plus lockup.

Like, #### magic, DPSG is seemingly the REASON for this issue!?!?

Edit:
So, it wasn't that it locked up RGB Plus, but that it crashed it entirely.
Edit2:
[Always something else with this...]
It's not that it crashed it entirely! It crashed in the Taskbar, but is still active in Task Manager.
What is even going on, at this point? Come on, throw me a bone here...

Share this post


Link to post
Share on other sites

I`m having the same problem. Plus i can not log in with 3 different emails i made and registered minutes before trying. PWM mode does not do anything it is the same on idle and under load. I can not control it with my phone because the app is unresponsive. I have deeply, deeply regretted my decision when i went with thermaltake, the fans are good. they are doing their job, i mean they would if the software would work properly or if you could be arsed to sort your buggy software out. Since i have these they are not working properly because of the software. Have you even tested before release? Not to mention that the 20cm fan starts to shake and being noisy like something caches the fan but i checked a couple of times and of course it is clear. The only reason i hadn`t changed it yet because i can not afford to spend 100-120£ for new fans. But 100% i won`t buy thermaltake anymore.

Share this post


Link to post
Share on other sites

I've had the RBG+ lock up issue from day one. Tried everything, nothing worked. About 3 or 4 updates ago they fixed it and it worked correctly. Now the latest update causes the program to not even launch. If launched manually, it dies.

Who the #### writes this #### code? Did they hire some #### idiot college kid to write it? There is no way a top tier cooling company should release such #### software and do nothing to fix it. It is embarrassing to have code released that is just poorly written garbage such as RGB Plus.

Share this post


Link to post
Share on other sites

Like mentioned. I'm in fear of my $900 CPU and $1,200 GPU to fall to the wayside of my AIO cooler, if this software is causing overheating for the AIO and causes it to spring a leak.

There will be a lawsuit if this becomes the case.

Edit;
Just updated. My app will not start, crashes on open, and is otherwise unusable.
Glad to see I'm having more problems. After having found a way to fix the previous one.

Share this post


Link to post
Share on other sites

ive also been using the TT flo ring with the RGB software for a few days now and all has been working fine. that was until i clicked the sync ram button in the TT RGB software....
immediately the app didnt like something and closed down.

At the time i was using my quiet movie mode RGB settings.

so now i cannot play games as the AIO fans will be overheating. - i have uninstalled the RGB app many times but each time i re download it it still somehow remembers what settings  i was last using. each time i try open the program it runs for 1 second then immediately closes. i tried using the phone app but that doesnt work at all.

if i could somehow get into the app and turn ram sync off i might be alright... 

edit: if nothing changes with the software or i dont get a response im returning this crap. litterally cannot play games on my 5k gaming system thank you TT

Share this post


Link to post
Share on other sites

ok i solved this problem: what happens is that the RGB software uses your IP address to connect your PC settings to your phone. so i guessed thats how they were saving my fan settings data even after i was reinstalling the software.

to fix this i completely deleted everything to do with the TT RGB software and redownloaded. do NOT install it yet, go into settings and turn of all ur internet connections and take out cables (go airplane mode). then once offline install the software and it will promp you saying that it has no internet connection, just continue and extract all the files.

this worked first time and the software didnt crash after 1 second and is still working right now :). will keep u updated.

Share this post


Link to post
Share on other sites

I had something similar happen. Reinstalling helped, no crashes for about 2 days. No tricks.
Now, suddenly crashing, why? It makes literally no sense that this app needs an IP at all.
Makes me wonder if the same RGB backdoor hack has something to do with it.

Share this post


Link to post
Share on other sites
On 12/11/2018 at 8:15 PM, jfs113 said:

let me know if you find a fix, for some odd reason, other then one of the newer versions, the TT RGB software freezes up my computer on start up? nothing with work and have to hard re start into safe mode to unistall software.

 

it worked fine for about 3 months and i have no new hardware but somthing is not liking TT RGB.

I’m having a very similar, possibly the same problem. If I have the software installed, my PC will freeze up. The mouse moves and it acts like I can click on things but the buttons don’t do anything. After uninstalling in safe mode all problems go away.

IF windows runs stable with the software installed the RGB control only works for a few seconds to a few minutes before the effects and speed control just stops. Opening the software, it’s like Windows, all of the buttons are there but the don’t actually do anything

Share this post


Link to post
Share on other sites

TT RGB Plus is the advanced Ecosystem is the intelligent lighting system for Personal Computer. It is the most effective way to addressable LED lighting with Thermaltake's patented TT RGB PLUS Software. If you have any problems with AOL then please contact Fix AOL Mail Error 100 for instant help related to AOL Mail.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×