Jump to content
ThermalMike

**ATTN Users with Thermaltake Riser Cables**

Recommended Posts

On 2017-5-6 at 3:52 AM, ThermalMike said:

Have you contacted me to send a replacement cable yet?

Please follow the template and email me again if so, will get you the new design to support your Thermaltake purchased product that came with a cable.

I know you are not in the USA, I can work with our team in your region to work something out.

I try to help as much as I can.

thx.

Yes I did contact you and yes they sent me another cable and it was the same cable and didn't work. I have had 3 cables so far. I have emailed you again, please make sure TT Australia don't send me any of their leftover old crappy cables please.

Share this post


Link to post
Share on other sites
On 5/4/2017 at 1:31 PM, ThermalMike said:

We also have a COMPLETELY NEW designed cable that is cheaper:

http://ttpremium.com/product/gaming-pci-e-3-0-x16-riser-cable/

Has anyone used this new "redesigned" riser? If so, what is your experience...

I have several builds that I'd like to use a riser for and so far I have refused to even attempt it... and I'm not charging clients for a $70 "premium" riser.

Share this post


Link to post
Share on other sites

UPDATE:

Received my new riser cable today, installed it and tested it. So far it's not causing any problems. *Fingers Crossed*

The cable I received -> None of the above actually. It's sort of the cheap one, with a different lock and no thermaltake branding what so ever... What I did notice was the black top layer is pasted on with adhesive, which came off straight away with the smallest amount of bending. (installed the cable in my core P3, and both ends have the black end parts loose reveiling the cable underneath, not sure if this will cause problems but I feel it's cosmetic at this point).

Will keep you updated if anything changes.

Special thanks to @ThermalMike for his quick replies, really sped up the process.

Share this post


Link to post
Share on other sites
On 5/11/2017 at 8:47 PM, copyright976 said:

so are the replacement cables you are sending out the "cheaper" ones or the "Premium" ones?

I received my replacement and it's the newly redesigned $29.99 branded model. I have a P1 and the replacement is much longer. Same part number as this guy although the beginning is different since it references an included riser versus retail. At least that is what support told me... I haven't used it so no feedback (yet).

http://ttpremium.com/product/gaming-pci-e-3-0-x16-riser-cable/

Share this post


Link to post
Share on other sites
On 4/29/2017 at 11:20 PM, Mac OSK said:

I am having the same issue with my Core G3. The riser cable made my system not booting, no posting beep.

Email sent last week. No reply.

 

Thermaltake ... please be seriously responsible on this issue.

Keeping thread running up to 10+ pages is unacceptable in product quality's perspective.

Hi TT,

Are you going to take responsibility on this? I sent an email a month ago, no reply.

Share this post


Link to post
Share on other sites
On 5/13/2017 at 9:54 AM, Mac OSK said:

Hi TT,

Are you going to take responsibility on this? I sent an email a month ago, no reply.

Hi Mac OSK,

I may not deal with your region directly, but I am happy to help all I can.

As the OP template is in the thread, please just follow the steps to contact us here in the USA.

We can direct the request over to help.

Feel free to CC me on the email if needed.

 

Share this post


Link to post
Share on other sites
On 5/18/2017 at 6:18 AM, ThermalMike said:

Hi Mac OSK,

I may not deal with your region directly, but I am happy to help all I can.

As the OP template is in the thread, please just follow the steps to contact us here in the USA.

We can direct the request over to help.

Feel free to CC me on the email if needed.

 

Thank you, Admin@US

I did push another email and got response from TT Taiwan.

They followed up with TT in Thailand for me.

I've just got new Riser cable from TT Thailand.

Tested it, working flawlessly.

Thank you.

Appreciated your reply too.

Share this post


Link to post
Share on other sites

Update:

Riser cable failed again. Sent another email.

Tried to order the premium one online because im sick of this **** right now. Guess what?! ''We are happy to offer international shipping services'' Grand total for the $69 cable you ask? $191. Id happily pay for the premium one if it solves the issue, but this is just borderline stupid.

Share this post


Link to post
Share on other sites

Yeah my wife bought me a premium cable from PLE for my birthday.  It was $85.still more than 69 on the Australian TT site but will see if this works. 

Share this post


Link to post
Share on other sites
On 2017-5-27 at 3:56 AM, Pyro2677 said:

Yeah my wife bought me a premium cable from PLE for my birthday.  It was $85.still more than 69 on the Australian TT site but will see if this works. 

And? Did it work?

Share this post


Link to post
Share on other sites
1 minute ago, Willem said:

And? Did it work?

Have been busy and need to move the WC tubes so going to have a crack at it this weekend if I get time. 

Share this post


Link to post
Share on other sites
On 2/3/2016 at 10:18 PM, ThermalMike said:

**ATTN Users with Thermaltake Riser Cables**

**UPDATED 5/3/2017**

If you are experiencing issues with your Thermaltake Riser Cable product, please help to contact our support for warranty replacement options.

Email Contacts:

USA/Canada/South America:
support@thermaltakeusa.zendesk.com

International Global Customers:
info@thermaltake.com

Subject: Thermaltake Riser Cable Request

What we need:
1. Motherboard Make/Model
2. GPU Make/Model
3. Your invoice/receipt
4. Brief description on the issues you are having
5. Your shipping address
6. Your Name
7. Phone Number (For shipping purposes)

Once your email has been received, please allow 1-3 business days for processing.
Due to region availability, some requests may be delayed.
 

I recently purchased a PCIe x16 Riser card which was instantly defective. After install my computer becomes sluggish and boots much slower. 

I have latency issues, lockups and audio artifacts or stuttering. When(or if) it boots to desktop, it stays on for about 20 seconds then cuts power and reboots. It won't run any of my 3D or editing applications – as soon there is expected load to the GPU the computer cuts out. I tried changing the bios settings on the PCI-E slot from AUTO to Gen 3, but the problems remain.

Without the riser card everything works flawlessly, but because of these power cuts I have now lost my WD Black 2.5'' 500GB HDD – so I am not only 46$ short because of this faulty riser card, but with a shorted out HDD I now have to bleed extra $ on a new HDD.

So extremely frustrating!


Motherboard Make/Model : Gigabyte GA-Z87N-Wifi Mini-itx LGA 1150

GPU Make/Model : GeForce GTX 1070 AERO ITX 8G OC

I sent an @ to support@thermaltake.de and cc’ed cs2@thermaltake, cs@thermaltake, mike.fierheller@thermaltakeusa.com and ttsupport@thermaltakeusa.com waiting for a reply.

Share this post


Link to post
Share on other sites

hello... has this issue been resolved... i'm expecting the P5 case June 29 2017... is Thermaltake still shipping the old problematic PCIE cables, with new orders... 6 months, after this problem started?

Issue resolved or not... sure would like a up-date... Thanks

Share this post


Link to post
Share on other sites
49 minutes ago, TomP5Build said:

hello... has this issue been resolved... i'm expecting the P5 case June 29 2017... is Thermaltake still shipping the old problematic PCIE cables, with new orders... 6 months, after this problem started?

Issue resolved or not... sure would like a up-date... Thanks

After getting 3 Replacement cables my wife got me a premium cable for my birthday and that works.

Share this post


Link to post
Share on other sites

so... the PCIE cables deal is still a problem... cause they just send you another cheap dis-functional PCIE riser... and not the one called TT Premium that supposed to work?

So now... I'm looking at a $225.00 case , if i have to go and buy a $100.00 Thermaltake Riser Cables, or another make... this is not a fair to the customers! 

I will check back soon!

Share this post


Link to post
Share on other sites
18 hours ago, TomP5Build said:

so... the PCIE cables deal is still a problem... cause they just send you another cheap dis-functional PCIE riser... and not the one called TT Premium that supposed to work?

They have revised the cable and stopped selling the prior version. I would presume older stock (of the cases) contain the older version. Physically they look a little different so one can probably tell which version you have... worse case they would ship you one of the new ones (not the premium version). 

The cable for my P1 is fine as well as a replacement they sent for a P3. Then again I don't game or whatnot. I did run one stress test for several minutes and it passed with flying colors.

Share this post


Link to post
Share on other sites

Hi,

 

I bought a new Core G3 on 29th June 2017 and I have the same problem with the Riser Card.

Email sent as per the original post, so I am now waiting to see if there is still support. My serial number looks low, which I guess means an old case.

PC doesn't boot, will not restart, cannot resume from sleep, sound poor in the 1 in 5 times it boots. It seems to be in batches, will work then suddenly stops. Very frustrating.

Edit:

The original cable, has the black shielding peeling off from one end and the overall feel is poor, the shielding is not smooth over the cable.

Share this post


Link to post
Share on other sites

never bothered with the junk cable.... (i'm not connecting a cheap cable to a $700 Video card) installed the video card direct to PCI slot on mother board... TT is ruining their market... with junk... now i got problems with junk fans... "Ring Plus 12" with the premium software...where it wont recognize the controller box... I doubt i will buy anymore of their product...really  junk! Sorry guys... but you are what you do! 

Share this post


Link to post
Share on other sites
On ‎29‎/‎06‎/‎2017 at 1:29 AM, TomP5Build said:

so... the PCIE cables deal is still a problem... cause they just send you another cheap dis-functional PCIE riser... and not the one called TT Premium that supposed to work?

So now... I'm looking at a $225.00 case , if i have to go and buy a $100.00 Thermaltake Riser Cables, or another make... this is not a fair to the customers! 

I will check back soon!

It's worse than that, you buy a PSU which fits the case (Core G3 for me), which is a SFX, so doesn't fit into a normal case. The motherboard is a full sized ATX, so all the mATX cases as a replacement are non-options.

So, either chuck the case and start over with a new PSU and accept a big ATX capable case, or spend more than the cost of the case of fixing the case.

This is not a good situation at all.

Share this post


Link to post
Share on other sites

So I'm having a little trouble figuring out exactly which products have an issue

So please correct me if I'm wrong here

-------------------------------

AC-039-CN1OTN-C1 <-- has issues, original riser?

AC-053-CN1OTN-C1 <-- new version, some seem to have issues with this as well? (Is this the one ppl are recieving as replacement for the first one?)

AC-050-CO1OTN-C1 <-- Premium 60cm version, no issues but kinda expensive? Also is there a shorter version ie. an 30cm version of this one?

--------------

 

If my above assumption are correct I need to get me the premium one correct? and not just the new version "AC-053-*"???

 

 

Hope some of you can help me clarify this, thank you VERY much in advance 

 

OleP

Share this post


Link to post
Share on other sites
On 7/4/2017 at 6:16 AM, katie1348 said:

Email sent as per the original post, so I am now waiting to see if there is still support. My serial number looks low, which I guess means an old case.

I would contact them via their RMA request page. I have always hear back within a day using such.

My take is if I have an included cable with the case outside of the P1 I would try to swap it. My P1 and replacement P3 cables have been fine although I don't stress them to any degree. Since this thread has become dormant (to a large degree) I'm guessing the newer version is working fine.

They switched to the 51 a while back and stopped shipping the 39 for replacements. Just checked on newegg and there are only two reviews for the 51 however both are five stars... it works. I'd give mine five as well although it's not nearly as "sexy" looking as the premium cable.

Share this post


Link to post
Share on other sites
15 hours ago, OleP said:

So I'm having a little trouble figuring out exactly which products have an issue

So please correct me if I'm wrong here

-------------------------------

AC-039-CN1OTN-C1 <-- has issues, original riser?

AC-053-CN1OTN-C1 <-- new version, some seem to have issues with this as well? (Is this the one ppl are recieving as replacement for the first one?)

AC-050-CO1OTN-C1 <-- Premium 60cm version, no issues but kinda expensive? Also is there a shorter version ie. an 30cm version of this one?

--------------

If my above assumption are correct I need to get me the premium one correct? and not just the new version "AC-053-*"???

Hope some of you can help me clarify this, thank you VERY much in advance 

OleP

I had a look online at the part numbers you showed and it looks like the older AC-039 part has a white and black lock on the PCI-E connector (the part that you plug your graphics card into) and the newer AC-053 has the more modern double black finger, the same as on newer motherboards.

There is a Premium Cable 300mm AC-045-CN1OTN-C1 on the Thermaltake website. Under Chassis and then Accessories.

http://www.thermaltake.com/Chassis/Accessories_/_/C_00003013/TT_Premium_PCI_E_3_0_Extender_300mm/design.htm

I hope this helps.

Share this post


Link to post
Share on other sites
1 hour ago, Charles R said:

I would contact them via their RMA request page. I have always hear back within a day using such.

My take is if I have an included cable with the case outside of the P1 I would try to swap it. My P1 and replacement P3 cables have been fine although I don't stress them to any degree. Since this thread has become dormant (to a large degree) I'm guessing the newer version is working fine.

They switched to the 51 a while back and stopped shipping the 39 for replacements. Just checked on newegg and there are only two reviews for the 51 however both are five stars... it works. I'd give mine five as well although it's not nearly as "sexy" looking as the premium cable.

I have had a reply and the Support Person in Taiwan said they would be helping me via a local distributor, I think. The email was written in non-native English.

"We would have our distribution to help.

Thank you."

So I am expecting a cable to just magically show up from someone either in the UK or Europe.

Share this post


Link to post
Share on other sites
8 hours ago, katie1348 said:

I had a look online at the part numbers you showed and it looks like the older AC-039 part has a white and black lock on the PCI-E connector (the part that you plug your graphics card into) and the newer AC-053 has the more modern double black finger, the same as on newer motherboards.

There is a Premium Cable 300mm AC-045-CN1OTN-C1 on the Thermaltake website. Under Chassis and then Accessories.

http://www.thermaltake.com/Chassis/Accessories_/_/C_00003013/TT_Premium_PCI_E_3_0_Extender_300mm/design.htm

I hope this helps.

Hi Katie, somewhat yes, I found the part number for the 300mm premium too, but thank you very much

As for the other cables, seems it's best to ignore them and just go for the premium.

Have a nice day ;)

 

/Ole P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×